Ignition automatic start in Mountain Lion Server

Hi

I have installed and manually run smoothly Ignition on latest Mountain Lion Server.
Also copied *.plist file to StartUpItems library.
Problem now is that I have to use sudo su to start Ignition gateway and automatic startup fails because permission denied.

Anyone solved this?

Br
Tommi

EDIT: I was wrong, autostart for Mountain Lion isn’t currently in the works, but it may be worked on in the future.

Maybe I am lonely OSX user but if somebody else is also “wise” enough to use OSX in Ignition platform, here is guide how to install Ignition to start automatically and still keep permissions safe level.
This works now only when using automatic login, there is some permission problems with wrapper if not using autologin?
I am using currently Mountain Lion 10.8.1
Older version has small differencies but I am quite sure that this works also older osx versions.

  1. Load ignition-osx.zip from Inductive Automation downloads section.

  2. Open terminal from applications

  3. Go download folder, so where you downloaded igniton-osx.zip, normally it goes under account folder Downloads
    cd /Users/“accname”/Downloads

  4. Give sudo su and password
    sudo su

  5. unzip ignition.osx.zip and make directory
    unzip -d /usr/local/ignition ignition-osx.zip

6.Go ignition folder
cd /usr/local/ignition

  1. Give executable rights
    chmod +x ignition.sh
    chmod +x ignition-gateway
    chmod +x gcu.sh

  2. Make new dir for launch alias
    mkdir /usr/local/bin

  3. Go new dir
    cd /usr/local/bin/

  4. Make link
    ln -s /usr/local/ignition/ignition.sh ignition

  5. Go back to ignition folder
    cd /usr/local/ignition/

  6. Copy startup list in daemons folder
    cp com.inductiveautomation.com.ignition.plist /System/Library/LaunchDaemons/

  7. Make plist load in startup, this will also start service right away and keep running always
    launchctl load -w /System/Library/LaunchDaemons/com.inductiveautomation.com.ignition.plist

  8. If you want to turn off your Mac you should stop service first from terminal.
    sudo ignition stop

  9. You can also manually restart,stop or start gateway
    sudo ignition restart
    sudo ignition stop
    sudo ignition start

Hope this help someone

Br
Tommi Vahtera
THT Control Oy

Thanks for posting that guide, this will definitely be of use for Mountain Lion users.

Awesome instructions. 11-14 now need to be added to the “Readme” file that comes from Inductive download page.

Thanks,
Michael

ok, it looks like something is not quite working when the computer starts. When it is working correctly I see an application called org.tanukisoftware.wrapper.WrapperSimpleApp in the dock. I’m assuming that this is the gateway running, but perhaps it is something else. It does always show up when I go to terminal and start the gateway.

On initial boot of the computer this file is not there and the gateway is running but not correctly. I cannot connect to it with anything (local or remote). If I go to terminal and “sudo ignition restart” it does stop ignition and then restart and the strange app shows up in the dock and then everything seems to work correctly from that point on.

I really do need to find a way to get the gateway to start automatically, or I need to have an executable on the desktop that will restart the gateway. I have some operators who will not be able to restart this without me and I do not want to get calls at 2am because the power dipped for a few seconds and the gateway did not restart automatically.

I’m running OSX 10.8.5, Ignition 7.6.3

The org.tanukisoftware.wrapper.WrapperSimpleApp is a executable that runs the Ignition gateway. I was able to successfully run vahterto’s instructions successfully on a Macbook Pro running OSX 10.8.4 (nice instructions by the way!) and the gateway starts without errors upon machine startup. So it’s hard to say why your gateway doesn’t automatically start. Maybe the ignition folder doesn’t have the correct permissions, or something like that. Is there anything interesting in logs/wrapper.log?

well, technically it does start. It just does not allow for any client connections. After booting, I can run the sudo ignition start and I get “Ignition Gateway is already running.” I can restart with the restart command or the stop command followed by the start command and both get it running correctly. Not sure why it does not run at boot. No errors in the logs that I can find. I’m only a few miles from Folsom…should I bring it over?

OK, I was able to replicate the client launching problem on our Macbook here. The good news is that the new native client launchers are able to work around the problem. The native launchers also have the advantage of being able to retry contacting the gateway forever until it finally finishes startup and responds. So if your box dies, and you have added a client launch to run at startup, everything should start up again after a few minutes.

ok, found the error I had. I did not have the user rights setup properly for one file.

In step 7 of the instructions above…
"chmod +x gcu.sh "

either I missed it or had a typo when I did it and it did not execute. Once this was fixed everything is working as desired…thanks.