Ignition cannot connect to Think-N-Do OPC. FactorySQL Does

I’m thinking of upgrading to Ignition. I downloaded the Demo and installed it on the same machine as my Factory SQL / PMI.

I cannot get Ignition to connect to my Think-N-Do OPC servers (I have 10 of them running windows 2k in various parts of the Factory)

Factory SQL connects OK, (has been for years)

I attempted to load Ignition on one of the Think-N-Do machines so I could try and use the Com Tunneling, but It doesn’t appear as if Ignition likes Windows 2K

If FactorySQL can connect to the OPCs, why can’t Ignition??

Any ideas???

JOhn

Hi,

The most likely thing that comes to mind is that FactorySQL has been configured (that is, dcom has been configured) in some special way that Ignition has not. In particular, the most likely situation is that you have FactorySQL either running as an application, or set to use a different account for the service.

Go to Control Panel>Administrative Tools>Services, and find FactorySQL. Is it running? If so, right click, select “Properties”, and then “Log On”. Is it set to the system account? If not, try setting the Ignition service to use the same account.

If it’s not that obvious, we’ll have to take a look at the specific error you’re getting, and see where to go from there.

Regards,

Colby;

Yes, they are both identical in all the tabs.

They are both “Local System Account”

When I originally bought FactorySQL - Did we also have an initial problem of not being able to connect to the Think-N-Do servers??? I seem to recall you guys did something to get it to connect… (Maybe take a look back in my account)

JOhn McAvoy

It’s very possible. I looked through your account, but didn’t find much besides a phone call in which we “gave you some dcom pointers”, so who knows.

That’s ok, we’ll just take this fresh. What we have is that FactorySQL and Ignition are on the same machine, both running as a service, and both set to use the system account. Could you tell me…

  1. Is the OPC server on the same machine, or remote?
  2. Does the OPC server run as a service, or as an application?
  3. What is the error reported by Ignition when it tries to connect?
  4. Run “dcomcnfg”, right click on My Computer (under component services) and look at the Default Properties tab - what is the Default Authenticaiton Level and Default Impersonation level set to?

That’s probably a good start. The error that Ignition is seeing is probably the first step, as that should give us some clue as to what’s going wrong. Also, you haven’t by chance installed the 64-bit version of Ignition, have you? That requires separate “opc core components”.

Regards,

  1. OPC server(s) are on remote machines

  2. They show up in Task Manager as a Process, they do not show up as a service.

  3. I go thru the “add OPC Server” when I finish, I look at the “Status” and it shows “Faulted” with the following error message:

com.jniwrapper.win32.com.ComException: COM object method returns error code: 0x80070005; E_ACCESSDENIED (Access is denied.)
com.jniwrapper.win32.com.ComException.checkResult(SourceFile:172)com.jniwrapper.win32.com.ComFunctions.coCreateInstanceEx(SourceFile:230)com.inductiveautomation.opccom.COMServerImpl$ConnectServerJob.internalRun(COMServerImpl.java:719)com.inductiveautomation.opccom.wrapper.OleJob.run(OleJob.java:50)com.jniwrapper.win32.MessageLoopThread$ThreadSynchronizedAction.run(MessageLoopThread.java:585)com.jniwrapper.win32.MessageLoopThread$LoopThread.run(MessageLoopThread.java:527)

  1. Authentication = “Connect”
    Impersonation = “Identify”

John Mc

The “Access Denied” pretty much says it all - DCOM :cry:

But ok, if FactorySQL can connect, and FactorySQL is a service running under the system account, the only real difference that I can think of is that FSQL tries to set the default impersonation level to “Anonymous” when it starts. Ignition can’t do this- so try changing it system-wide from the DCOM config “Default Properties” tab. The Default Authentication Level can stay at connect, though if it doesn’t work after restarting, try “None”.

You may need to restart Ignition or even the machine for this to take effect.

Let me know if that helps at all,

No good.

changed Impersonation to Anonymous and rebooted… FSQL still connects OK, Ignition same error.

Changed Identity to NONE and rebooted, same, FSQL connects and is happy, Ignition same error.

JOhn

Hi,

Hmm, ok. So the OPC Server is on Windows 2000, and FactorySQL and Ignition are on what? At this point I can’t really imagine how Ignition looks any different to the OPC Server machine than FactorySQL does, but I believe that on Windows 2000, we can fairly easily find out by turning on DCOM logging, as detailed in this thread.

If you enable the logging (I don’t believe any sort of restart should be required), after a few minutes (because Ignition will try to connect every 60 seconds), you should see messages in the Event Log on the OPC Server machine detailing why access is being denied.

There are a few other relatively quick fixes that might work:
a) If the computers are all on a domain, pick and account that has admin rights to both machines, and set the Ignition service to run as that.
b) If not on a domain, create an admin account on both machines with the exact same Name and Password. Then set the Ignition service to run as that. When an account has the exact same credentials on two machines, DCOM allows remote access more or less as if it were local.

Regards,

NO GOOD

On the Server 2008 computer

I tried running the Ignition Service as the same username password as all the Win2K ThinkNDo computers. The service would not start, I was getting Illegal username password. when I tried to start the service.

On one of the Win2K ThinkNDo computers.

I changed the login/ username/password on one of the TND computers to match the Sever 2008 computer. I rebooted and the TND came up.

FSQL was still connecting to it OK, Unfortunantly, same problem with ignition, I can set up the remote DA server (it is finding the OPC server with OPCEnum. but it fails to connect, with the usual Access denied error.

Just to get a third data point on this problem, I downloaded and installed Iconics DataSpy. It had no problem connecting and displaying data from the TND servers,.

Want me to send you a computer that has TND installed and running??

JOhn Mc

… most likely because it wasn’t running as a service, but instead under the user account you were logged in as.

Instead of mailing computers, if you can get to them from a machine that has access to the internet, you can just call up tech support and they can troubleshoot over GoToMeeting.

Before you can do this, you have to actually create the account on the machine so that it matches the account on the other machine.

Did you try turning on the dcom logging on the window 2k machine? That would probably indicate which particular permissions were missing. Again, though, if these machines are somehow accessible over GoToMeeting, one of the guys here could help.

Regards,

The Server 2008 machine can do goto meeting. not sure about the Win2K machine.

Let me see if I can turn on dcom logging on the Win2K machine…

John Mc

No good on the Win2k event viewer (log) I clear the log, rebooted, then made attempts with FSQL, OPC Spy, and Ignition. nothing showed up in the logs. FSQL and OPC Spy can connect and view tags and data, Ignition can see the OPC server (OPC Enumerator) , but will not connect.

FYI - I’m about 95% sure we had this same problem with FSQL back in 2005 or 6 when I first demo ed FSQL before buying it (You might check your REV log to see if there is anything there that might shed some light on this… I tried to find e-mails from back then but my e-mail server got cleaned in 2008.

Anyway, what else can we do to resolve this. I’ll be out in Calif in a couple weeks and can either mail or bring a Win2k machine with ThinkNDo with me . My availibity between now and then is sporadic as we are harvesting crops right now.

John

I found a handy little tool for assisting in troubleshooting OPC stuffs.
http://advosol.com/p-22-opc-security-analyser.aspx You’ll have to register but it is free to use.
Lets you see all the settings in one place and do test connections in different ways.

Helped me out when a patch blew our dcom settings away…

Dravik;

Thanks for the link, I downloaded and installed on the FSQL machine. I didn’t see anything unusual. I couldn’t get it to install on the Win2k machines.

Sure wish we could get this working… I’m going to put a computer in the truck with me and when I pass thru Sacramento, I’ll stop by an maybe spend a day with them (if this is OK with them)

JOhn Mc

Remote DCOM is fun isn’t it?

Are you passing the CLSID of the OPC server(under the advanced stuffs) in the ignition config?

OK - The next iteration -

I’ve tried changing names, passwords, I have never been able to get Ignition to talk to the OPC server. I get past the OPCenum, but the status fails as access denied…

Heres our latest attempt - I have a new install Windows XP machine, I loaded ThinkNDo on it and am running a control project.

On the Server 2008 machine running FSQL and Ignition, FSQL connects and talks to the OPC on the XP machine. Ignition does not.

I tried to load Ignition on the XP machine, but the install hangs (version 7.3.4). I’m going to re-image the XP machine so I can start with a fresh XP install, and try loading Ignition before I do anything else.

John Mc

I’m downloading what appears to be a trial version of Think & Do now. Still though, if you’re getting “Access Denied”, it probably has nothing to do with the actual OPC server itself. If you happen to be coming by the area, feel free to stop by.

I’ll let you know if I find anything with the demo.

Regards,

Why not use Ignition’s OPC-DA to OPC-UA tunneler?

Originally he had the OPC server running on Win2k, and was having some difficulty getting Ignition to run on that. If a different host os is used, he could probably just run Ignition side by side to start.

I got the demo installed, and Ignition connected without problem locally, but immediately disconnects because the server says that it’s “not configured”. I couldn’t immediately figure out how to configure it, but maybe I’ll give it another look tomorrow.

Regards,

Colby, I did a fresh WinXP install on a test machine.

When I attempted to install Ignition , it had a problem when it tried to install Java.

I download Java 6 and installed it.

Ignition now installed OK.

When I open up “Ignition Gateway Control Utility”, I get Web Server Stopped, Gateway stopped, Port Unknown, and SSL port Unknown.

Any quick suggestions?

(WinXP firewall is OFF)

JOhn Mc