Ignition changes JAR file names artificially

I made my module with a 3rd-party JAR file. The 3rd-party JAR file name is sapjco3.jar, and the JAR file is not supposed to change its name. If this JAR file name is modified, then an exception will be occurred.

But, when I install my module on Ignition, Ignition changes this jar file name sapjco3 artificially like that:

…\Inductive Automation\Ignition\temp\ sapjco3340385287549517404.jar
…\Inductive Automation\Ignition\data\jar-cache\sapconnectorgateway\ __ 2224554137 __ sapjco3.jar

When I run my module, Ignition loads sapjco3340385287549517404.jar. And the exception is occurred because JAR file name is not sapjco3.jar.

How can I solve this issue?

I’ve seen this same issue, with this same jar, once before. You won’t be able to load it from a module.

A workaround might be to just drop the jar file into the lib/core/gateway folder of your Ignition install.

Relying on your own JAR file being any certain name is pretty absurd practice.

I already tried the method that you mentioned. But, Ignition still loads sapjco38096529840247398430.jar of the Ignition\temp folder even though I drop the JAR file sapjco3.jar into the Ignition/lib/core/gateway folder.

Any idea?

Right, looks like we do the same thing with the platform JARs.

Unfortunately I don’t think there’s anything else you can do here.