Ignition Designer Hangs during development

Hello All,

I am using Ignition 7.3.7 32 bit on my fedora 14 linux. It was working good on my laptop for last 1 year or so. But when I didnt access it in last 2-3 months and today I am working on the project and in between it hangs and I have no other option other than restart my PC…

Please help it is killing my time!!!

I was also experienceing designer freezing/hanging for awhile and I didn’t know why it was happening. But this problem went away when I upgraded Ignition. Now it doesn’t happen anymore. I suggest that you upgrade your Ignition. The current version is 7.6.4.

Other than that the designer can hang/freeze if you are doing something in the designer to cause it to freeze. For example if you are testing a script in the designer and the script goes into an infinite loop then the designer will hang. Or if the designer is made to do something else that is very CPU intensive that it can’t complete or takes a huge amount of memory then it can freeze.

You shouldn’t have to restart your computer. Usually an operating system provides a way to get to a process list so you can kill the java process that the designer is running in.


I am not executing any scripts in designer. I got some scripts in runtime.

The other option of upgrading version is I dont know whether it is feasible or not since we have intercompany software that all group company uses. I m not sure that my existing 7.3.7 app backup will work on this latest version or not.

I tried ignition on other PC and it works fine!! may be there is some issue with Linux OS…

Is 7.3.7 version application run on lates version? or are there any dependancy???

[quote=“ashish007pict”]I tried ignition on other PC and it works fine!![/quote]FWIW we have noticed that it performs much better under windows than in a mac environment…maybe you have a windows vm you can run it in?

I cant change my OS since I have some other recipe calculation application works on Linux and I have to transfer data calculated by recipe calculation app to AB/Siemens?Mitsubishi PLC!!!


As an alternative you can also try updating to the most recent release of 7.3.9 to see if this resolves your issue.

If you would like to upgrade to 7.6.4 I would suggest doing an incremental upgrade. Upgrade to maybe 7.5.4, then 7.5.11, and finally 7.6.4.