Ignition Designer updating with old information

I have seen this problem randomly from time to time, and today I was able to get my best look at it yet. It is very strange, so I will try to do my best to describe it. If I open up a project in designer and make changes to a page, and then update it sometimes I notice strange things happen in other windows of the project that I did not go to or change. For instance I changed scripting in a script module, updated the project and found that a button I had added to an unrelated page had disappeared in the client. I opened designer back up, went to the project and page, saw that the button was still indeed there, saved the project with that window open and then the button reappeared. Today I made some more scripting changes on a different window, and some modules. I opened up my client and launched my project and was in the process of navigating to the windows I made the changes on. One of the windows I navigate through gave me an error saying that it could not find the window named “SETUPPW”. This is strange because I deleted the window “SETUPPW” 4 weeks ago and changed the scripting to reflect the new window “USERPW”. The project had worked with this change in effect for the last 4 weeks without any issues. Somehow a window I did not do any work to had reverted back to a previous state from 4 weeks before. I opened up designer, and the window that is now giving me the error with the scripting. I found that the scripting was calling for the correct window “USERPW”, and there was no reference to “SETUPPW”. I did a FIND for SETUPPW in the entire project and none was found. I saved and updated my project, saw the client update, and it still gave me the error that it was trying to open “SETUPPW” even though the code was no longer there to do that. I saved a backup of this gateway, and decided to have some fun. I deleted the button that was giving me the error and several objects on the screen and saved the project, and the button and objects were still there. I next restarted my gateway, and the clients still had the old window in there. I next saved a gateway backup, and loaded it onto another ignition gateway, and all of the changes I had made now showed up. However when I tried to edit this same window on this new different gateway, any changes I made were still not appearing to me. So I deleted the entire window (SCANENTRY), and saved, and I was still able to navigate to it. Now I know what your thinking, because I thought the same thing, that I have a designer and a client open from two different gateways, but when I went in and deleted objects and windows other than the (SCANENTRY) window, I was immediately able to see these changes once I saved. Only changes made to or on the (SCANENTRY) window were not updating. So on my 2nd gateway I decided to export, delete, and then reimport the project, once I did this I was not able to get to my invincible deleted window anymore. So I went back to my first gateway, launched the project again, and now the scripting was working like it was supposed to … I even could see where I had slightly moved the button. So I went into the designer to see if I could now edit the window, and success, the window is not invincible anymore. So I don’t think it is broken anymore, but I am not really sure, as the things that break are not the things I am working on. The customer may call later today and tell me something disappeared on another window (that’s how I usually learn this problem happened), and I will open the project to see another object or script that has reverted to a previous state in the client, but is still updated to its current form in the designer.
Yep its strange
Running ignition 7.6.6

I saw this problem come and go two more times today. Sometimes when launching the client it would call the old script that isn’t there, and then sometimes it would call the new correct script that is there. I also saw it happen on another one of my gateways. It could be possible that the gateway backup itself is corrupt as the other gateway I saw it happen on is a copy of the first one. I did find something interesting though, it seems that this issue is related to how I access the ignition homepage and launch my clients. The normal way I have been accessing my clients is by typing the following into the address bar: “http://myservername:8088”. While troubleshooting this issue today I happened to open up the server address by using an old favorite link I had, and the problem seemed to go away, and my new scripting was working fine again. I checked the favorites link and it was pointed to: “http://myserversipaddress:8088”. An engineer then called me later today and told me he was getting the same error I had earlier, and I verified with him that the old script was calling for a window that is no longer in existence. I told him to change the server name in the address bar to the IP address and re-launch the client, and the scripting worked as it should have, calling the new window. I will try to navigate to my clients using only the IP address to see if that will eliminate my issue.