Ignition Edge fails to start on Raspberry Pi

this was a working project on a raspberry pi. I ran the commands sudo apt-get update and apt-get upgrade which kicked off this issue.

some key lines in the log file

OpenJDK Client VM warning: You have loaded library /usr/local/ignition/jre-tmp/sqlite- which might have disabled stack guard. The VM will try to fix the stack guard now.
INFO   | jvm 1    | 2023/05/15 12:57:11 | It's highly recommended that you fix the library with 'execstack -c <libfile>', or link it with '-z noexecstack'.
INFO   | jvm 1    | 2023/05/15 12:57:11 | Failed to load native library:sqlite- osinfo: Linux/aarch64
INFO   | jvm 1    | 2023/05/15 12:57:11 | java.lang.UnsatisfiedLinkError: /usr/local/ignition/jre-tmp/sqlite- /usr/local/ignition/jre-tmp/sqlite- wrong ELF class: ELFCLASS64 (Possible cause: architecture word width mismatch)
INFO   | jvm 1    | 2023/05/15 12:57:11 | 12:57:11,249 |-WARN in ch.qos.logback.core.db.DataSourceConnectionSource@62feac - Could not discover the dialect to use. java.sql.SQLException: Error opening connection

wrapper.log (7.6 MB)

I think it's the same issue as this thread: Gateway Startup Failed Raspberry - #12 by Kevin.Herron

Which essentially boils down to: you have a mismatch between OS/hardware arch and the version of Edge you downloaded.

I suspect that the newer RPi4 with 64-bit CPU require a 64-bit OS to match for 8.1.22+.

1 Like

Ok. thank you for the reply.

It's strange that it was working but now isn't. I can't readily explain that.

updating to the 64 bit OS worked. Cheers!