Ignition Gateway doesnt start after upgrade on Ubuntu

I recently upgraded the Ignition to 7.6.2-rc3 on Ubuntu. After the upgrade from 7.6.1 to 7.6.2-rc3 the gateway doesn’t start at all. I reset the Hardware and even rolled back installation to previous stable release but it doesn’t start at all. Please Help.



Can you get the wrapper.log file and post it here as an attachment?

Hi Kevin,

I tried uploading directly here. It has been uploading for last 50 minutes. I will keep it running, However I uploaded it on this link.




How did you originally install this Ignition and what method have you used to go about upgrading it?

I didn’t install ignition originally. I can get more information on that.
However I downloaded,

files.inductiveautomation.com/re … taller.run

Sudo chmod +x ‘ignition-7.6.2-rc3-linux-x64-installer.run’
Sudo ./ignition-7.6.2-rc3-linux-x64-installer.run

We just hit this during our internal testing. Here is a workaround that works for us:
Navigate to your Ignition install folder (most likely under /usr/local/bin/ignition) and then navigate to the /lib folder. Within the /lib folder, create a temp folder (note that you must have sudo access):

sudo mkdir temp

Then make that folder accessible to the user running Ignition:

sudo chown yourusername temp

After this, your Gateway should be able to start. We are implementing a fix to take care of this issue, which will be part of the next 7.6 RC.

Thanks guys.

I worked.