Ignition Gateway v8.0.13 not working after restarting of Advantech Screen Panel (PPC-4151W)

Hi All

I am using Advantech Screen Panel (PPC-4151w), to use it as a Ignition Edge Gateway/Ignition Gateway.
When i first install the software, everything is fine, gateway running.
When i do a restart of the panel, the gateway doesnt seem to be running anymore (localhost:8088 is unable to open). It would only work again if i re-install the gateway. After i restart the panel, again the gateway is not working anymore. i have tried with version 8.0.16, i thought was a version issue, hence i tried with 8.0.13, but the problem still persist.

I went to have a look at the Services after a restart. The Ignition Gateway and Ignition_Gateway are both set to start automatically, but they are all stopped.

Another thing is that, there are 2 gateways (As per attached picture)

Is ‘Ignition_Gateway’ causing some issue?
Because on my own laptop, i only have one “Ignition Gateway”

Could someone kindly advise me how could i go troubleshoot about it?

Thank you very much.