Ignition Git Module SSH Key not working

Hello everyone,

I'm having some issues with my install of the Git module for Ignition.

I have been following this documentation on the install.

In the section for generating your ssh key it has you use the following in the command prompt

ssh-keygen -m PEM -t ecdsa -b 521 -C "your.emailadress@gmail.com"

I have done so and then went to go and paste my ssh key to my git account. It then gives me the following error

Can not verify your SSH key: SSHKeyGenParsePublicKey: fail to parse public key: exec: "ssh-keygen": executable file not found in %PATH% -

I can't figure out what the issue is here. I know that I have it in the correct path. The path being C:\Users\myusername\ .ssh

I've tried generating a new ssh key and it still doesn't work for me. Any help would be greatly appreciated!

So I have been working on this issue and still haven't had any luck. But for anyone who's curious I thought I would tell you all what I have done to try and fix this issue.

This is the file path and name of my key:

File Path:
C:\Users(account name).ssh

File Name:

Beginning of SSH Key:

I checked the environment variable and the path was the following:


I added the following to the environment variable at the recommendation of this Git Forum Fail to generate private key: exec: "ssh-keygen": executable file not found in %PATH% - goroutine 1 [running]: · Issue #4651 · gogs/gogs · GitHub
But that didn't fix the issue.

C:\Program Files\Git\usr\bin

In the video they use the following to generate their SSH Key. I tried this and it didn't fix the issue.

ssh-keygen -m PEM -t rsa -b 4096 -C "youremail@email.com"

And when I tried this my key was not an rsa like there's, which I'm not sure if that is an issue or not.

Also of note, I am trying to paste this key into my SSH Key Manager of my account at my companies Git.

I hope this provides more insight into what could possibly be the issue. Thank you to anyone who could help me with this!

So I'm back with another update, and the solution was finally found!

I'm reminded of Occam's Razor, "The simplest solution is often the best". All I had to do was use a URI instead of a SSH Key :man_facepalming:.

The company I work at uses Gitea, and it wasn't configured to use SSH Keys. Instead we use the URI.

So just know that if you're given the error of

Can not verify your SSH key: SSHKeyGenParsePublicKey: fail to parse public key: exec: "ssh-keygen": executable file not found in %PATH% -

That it could be you need to use the URI instead!

1 Like