Ignition launching problem


Yesterday We install three Ignition instances succefully (1 per plant). The problem is that in some of our computers We get the following error (watch the attached figure) when We try to launch the client or the designer. This error happens with JAVA and Personaly I have the version but happened to me once too.

I don’t know if it’s a problem if we have one version of Ignition ( 7.1.8 ) installed with the EXE way and the other two (7.2.3) with the zip way (changing the ignition service name, ports, etc.)

Can anybody tell me something about this?. The reason that I’m trying to do this are explained in this post (viewtopic.php?f=70&t=6210)

Thanks in advance.

any news?

Check the Gateway’s logs to see if it is logging an error at the time corresponding to the client launch problem.


It seems like It’s nothing in the wrapper file (I attached anyway). Now I don’t know why but the previous message were not showed anymore but, i have another message related with sockets problem (I attached a screenshot too).

In this instance of ignition i have two apps , but I have problems with only 1 of them. In fact, I have no problems launching the designer. Something strange about this is that the message only appears when I launch the windowed version of my app. If I launch the “Full Screen” version It opens perfectly. If I launch the app through the designer, It only works with the “stage” version (F9). The “F10” version throw me the same error.

Do you have any idea of what is this?

Again I tell you that I’m running simultaneously 2 Ignition instances. The first instance is an Ignition 7.1.8 installed with the “EXE” common instalation. The other is an Ignition 7.2.3 installed by command line following the instructions that I showed in the previous post.

Thanks in advance for the help.
wrapper.log (103 KB)

I don’t have any idea. We’ll try to mock this up on our end and see if we can reproduce the issue.


Yesterday I changed the gateway port from 8089 to 9088. I don’t know if there is a issue with the previous port, but with this little change, I solved the problem momentarily. In fact, my second instance of Ignition is running so much better now. Anyway, I’ll tell you if the socket error appears again.

Cheers from Chile.

Interesting, sounds like it has to do more with the networking on that machine than with our software. Hope it continues to work for you.