Ignition License Missing / Help Required

Today we tried to upgrade the Ignition Modules ( Siemens drives and Activex Modules) for test purpose and we had a fault on the context
And later I tried to do the version to the Latest Version Version: to have fix this issue
Release Date: Jun 29, 2011

And the context has faulted Again, So we tried to remove the context manually and paste in other location so that I can recover
Then I restarted the context and the context started without any problem and I thought of uploading my gateway backup to the IGNITION SERVER
But this did not happened, instead I had fault reappear again

Since I was running old version of the Ignition (version 7.2.7, 1 April 2011) I tried to remove and install earlier version
And Now the Status of the Installed License is License Expired

Could you please advise the procedure for recovery of my Igntiion Server License and explanation why this has happened,
Waiting for you reply as soon as possible

Your sales rep can help reset that license for you. PM me if it’s an emergency.

License files reside inside the context directory; it sounds like you moved your context directory somewhere else and then reinstalled.

If you haven’t deleted the context you moved you can take the license.ipl file and move it into the right location.

Hi, Yeah I have tried that thanks for the updates It worked
I am discussing this issue with the Account Rep for permanent solution

Plant wont stop for even a minute and this type of context failure on update of some modules
is not good!!! whats your opinion???

If you post your wrapper.log files (likely located in C:\Program Files\Inductive Automation\Ignition) we can take a better look at what’s happening.

Do you happen to have the OEE/Downtime/Production modules installed too?

Zip the log files and either upload them here or email them to support@inductiveautomation.com

OK, I will try to Post it,

But after successful restoration,
We have the following error,
sun.security.validator.ValidatorException: PKIX path validation failed: java.security.cert.CertPathValidatorException: java.net.UnknownHostException: ocsp.comodoca.com
at sun.security.validator.PKIXValidator.doValidate(Unknown Source)
at sun.security.validator.PKIXValidator.doValidate(Unknown Source)
at sun.security.validator.PKIXValidator.engineValidate(Unknown Source)
at sun.security.validator.Validator.validate(Unknown Source)
at sun.security.validator.Validator.validate(Unknown Source)
at com.sun.deploy.security.TrustDecider.isAllPermissionGranted(Unknown Source)
at com.sun.javaws.security.AppPolicy.grantUnrestrictedAccess(Unknown Source)
at com.sun.javaws.LaunchDownload.checkSignedResourcesHelper(Unknown Source)
at com.sun.javaws.LaunchDownload.checkSignedResources(Unknown Source)
at com.sun.javaws.Launcher.prepareResources(Unknown Source)
at com.sun.javaws.Launcher.prepareAllResources(Unknown Source)
at com.sun.javaws.Launcher.prepareToLaunch(Unknown Source)
at com.sun.javaws.Launcher.prepareToLaunch(Unknown Source)
at com.sun.javaws.Launcher.launch(Unknown Source)
at com.sun.javaws.Main.launchApp(Unknown Source)
at com.sun.javaws.Main.continueInSecureThread(Unknown Source)
at com.sun.javaws.Main$1.run(Unknown Source)
at java.lang.Thread.run(Unknown Source)
Caused by: java.security.cert.CertPathValidatorException: java.net.UnknownHostException: ocsp.comodoca.com
at sun.security.provider.certpath.PKIXMasterCertPathValidator.validate(Unknown Source)
at sun.security.provider.certpath.PKIXCertPathValidator.doValidate(Unknown Source)
at sun.security.provider.certpath.PKIXCertPathValidator.engineValidate(Unknown Source)
at java.security.cert.CertPathValidator.validate(Unknown Source)
… 18 more
Caused by: java.net.UnknownHostException: ocsp.comodoca.com
at java.net.PlainSocketImpl.connect(Unknown Source)
at java.net.SocksSocketImpl.connect(Unknown Source)
at java.net.Socket.connect(Unknown Source)
at sun.net.NetworkClient.doConnect(Unknown Source)
at sun.net.www.http.HttpClient.openServer(Unknown Source)
at sun.net.www.http.HttpClient.openServer(Unknown Source)
at sun.net.www.http.HttpClient.(Unknown Source)
at sun.net.www.http.HttpClient.New(Unknown Source)
at sun.net.www.http.HttpClient.New(Unknown Source)
at sun.net.www.protocol.http.HttpURLConnection.getNewHttpClient(Unknown Source)
at sun.net.www.protocol.http.HttpURLConnection.plainConnect(Unknown Source)
at sun.net.www.protocol.http.HttpURLConnection.connect(Unknown Source)
at sun.net.www.protocol.http.HttpURLConnection.getOutputStream(Unknown Source)
at sun.security.provider.certpath.OCSP.check(Unknown Source)
at sun.security.provider.certpath.OCSPChecker.check(Unknown Source)
… 22 more

I cannot launch runtime or Designer,
Certificate fault

We’ll need all the wrapper.log files please.

In regards to the “PKIX path validation” problem: Go to Control Panel>Java, and then to the Advanced tab. Expand “Security”. Are either of the following two options selected?
“Check publisher certificate for revocation”
“Enable online certificate validation”

If so, try deselecting them. We’ve seen this issue before, and it was due to these options being on, but the client not being able to access the internet. If neither of these options are turned on, let us know and we’ll look into it further.


Thanks for your Help
it worked for me…
Ignition_WRAPPER_.rar (369 KB)