Ignition - Licensing issue - 8.1.33

Licensing issue when we upgrade from 8.1.31 to 8.1.33

Our license work on 8.1.31 but not on 8.1.33, we have deactivated from 8.1.31 but unable to activate on 8.1.33

What part of the license works or not works?

Did you upgrade in place? (License should have continued working.)

Otherwise, did you deactivate the license on the v8.1.31 server before activating on the v8.1.33 server? The license can only be installed on one server (at a time).

We did an upgrade, so we have installed 8.1.33 over 8.1.31.

First we have let 8.1.31 activated (we always do that and everything goes well).
After upgrade to 8.1.33 license seems to be missing. We have roll back to 8.1.31, licencse working again, we have deacticated the license, reinstalled 8.1.33 then trying to activate the license but it doen't work :frowning:

For now we have rolling back again to 8.1.31

Do you have log files from after the upgrade? What symptoms of the "license not working" did you observe?

Nothing special in the log, we only see when we have did test of unactivation/activation on version 8.1.31, nothing logged as "LicenseManager" for 8.1.33 except when we have strated the Trial to test if pages worked in perspective

got that in the log

LicenseManager 06Nov2023 07:49:34 Error getting system ID: java.lang.Exception: Native library was not successfully loaded, cannot get system ID.


The system ID is Ignition's fundamental key that ties a license to an installation. It uses a native library for securely doing so. Your deployment environment is preventing that from working. You will definitely need to work with support to find out why.

Old thread, but I ran into this issue when upgrading from 8.1.24. The issue was resolved with a Clean install vs. doing an upgrade. If you have this flexibility with your production environment, this may work for you.

1 Like