Ignition opc connection to codesys gateway server

hi all,
i am trying to connect to my codesys gateway server without success so far.
can anybody help please?
greetings from austria

error codes or LOG could be good to help you!

I am using the Ignition OPC-COM module with the Panel Edition in a pc that has Bosch-Rexroth’s Indramat VM-11 installed. VM-11 installs and uses CoDeSys 2.3 as the PLC in a motion control system.

Getting things to work was not easy, and I could not get it to work on Windows 2003 server for some reason.

Ignition installs itself as a process under the user SYSTEM.

Your CoDeSys stuff is probably running under the user where you installed it.

Use Matrikon’s Explorer or something like it to verify that you can read tags from the CoDeSys OPC Gateway.

In my case Ignition and CoDeSys were using COM and not DCOM, but permissions for all these have to be correct.

There is a helpful 3rd party utility …

It will work.

Dennis

Hi,

As Dennis mentions, you will likely need to change the Ignition service to run as a user account. Go to Control Panel>Administrative Tools>Services, find Ignition, right-click and select “properties”, and modify the log-on tab. Set it to log on as the same user that is currently running the CoDeSys server.

This knowledge base article talks about DCOM settings. Look at the section that describes running the OPC server as the “interactive user”. I believe the CoDeSys server benefits from this, as well.

Beyond that, any other information you can give us about error codes or the like would be helpful.

Regards,

There are no error codes, as the connection connot be established at all

Matrikon Explorer works perfectly all the tags are browsable…

[quote=“Colby.Clegg”][/quote]
I’m using XP and all services run as “Local System”

Which one are you reffering to? Matricon Explorer?

Hi,

If the matrikon explorer works, it’s likely a problem with Ignition running as a service, trying to access the CoDeSys opc server, which is (almost certainly) running under your user account. Many OPC servers, unfortunately, are written in such a way that they only expect connections from visible applications run by the user, like the matrikon explorer. When services, like Ignition, try to connect, there are sometimes problems with security (dcom, which is normally for remote connections, but also applies to situations like this), or with configuration (the opc server might store it’s config file in a user directory, for example).

I would try one quick experiment, to see if anything changes: You are currently able to connect (through the explorer) while logged into the machine, using a certain account. Try going to services and changing Ignition to run as that account.

When the Ignition service restarts, see if the connection state has changed. In the gateway, under Config>Console, there will be some sort of message for the failed connection if it still doesn’t work. If you’re not sure, track down “wrapper.log” in “{InstallDir}\logs” and attach it here.

If it connects, but still doesn’t work correctly, open the window task manager and go to “processes”. Make sure you have the “Show processes from all users” box selected. Sort by name, and track down the process for CoDeSys (should be somewhat obvious). Are there multiple? What User Name are the reportedly running under?

Regards,

The Free OPC Security Analyzer is at

advosol.com/

Sorry for the delay getting the info back to the forum.

Colby: How do I embed a jpg or equiv in a reply? I’ll take some screen shots and post what is working.

Dennis

ok, da connection is established an i see my tags in the designer.
thanks to all.

next problem:
i am not usin a database - can i monitor tag values from the opc in the designer or does this require a database?

Ignition has an internal realtime database that contains the tags.

If you want history or trending on the tags you have to have an external database.

Otherwise, you can display anything in realtime.

Dennis

Colby,
I am running the latest version 7.5.6 now.
I still have the issue when browsing the CoDeSys OPC server of seeing folders for every tag name and then a tag with the same name. The software is running on a slow box under xp and it takes about 12 seconds to populate the browse tree with tags.
Before I had the issue where SQL Tags would lose connection to some tags after a browse. That seems to be fixed now. It will reconnect.

Don’t know why the duplicate names for empty folders and tags.

Thanks

Dennis

How do I configure this internal database?
Designer gives fatal error of transaction group because lack of default database…?
Furthermore I cannot drag+drop from opc-browser to sql-tags according to manual.
it works if I rightclick and add a new tag where i choose from opc-browser but this ist longlasting+ complicated…?

To remove the transaction group error, just set your project to a default database connection or choose a specific database connection in the group. You can set the default database in the designer under Project > Properties on the Project > General tab.

Unfortunately, your OPC server doesn’t support browsing so you can’t drag and drop into SQLTags. However, once you create one tag you can export the tag to CSV and create more than you can import in.