Ignition OPC - DA problem

Hi I have a problem with OPC-DA COM

Right now I’m using a ICONIC Modbus OPC server. When I run the ICONIC server and it’s client I’m able to browse the tags fine. But when I try use OPC-DA COM it give me a connection error. I won’t be able to Browse any data and the server shows connected.

I have several OPC server running on my PC Include Cogent Datahub and Kepserver, I don’t know if this could be the cause.

I have already tried the account setting in dcomcnfg and it didn’t help.

If there’s any other OPC server I can use for modbus that doesn’t have a problem with ignition also works for me.


If it’s a modbus device you’d like to connect to, you can try the Ignition OPC-UA Server which has a modbus driver.

Thanks for the reply. That’s actually what I tried to do originally. But I have a Modbus serial device. When I choose from new device do I add a RTU over TCP? And also for the address setting, what do I exactly put down for address if I want read 40001 a holding register? From the manual I can’t really sure if I need to put 40001 or 1 with a holding register type address.



If you can browse but not get data back, there must be a problem with the DCOM settings somewhere. The error in your first post is probably not the problem. Try subscribing to a tag, either in the quick client, or by making a tag in the designer. I suspect you’ll see new error messages showing “ACCESS_DENIED” or something similar.

There are many posts on the forum here, and outside whitepapers, about how to set up dcom. If you just search the forum for “dcom” you should be able to find them.

Ultimately you should be able to connect to it without a problem. However, if you also happen to have Kepware on there, and it’s the newer v5, you have the ability to connect through OPC-UA and skip all of the COM stuff.


Thank you very much for the help.
I looked up more information on DCOM and finally manage to make it work when I change all the user log on to launching user. The interactive didn’t work for me because I might have too many OPC related application on my PC trying to access to the port.