Ignition Perspective Powerchart tag path is not returning the correct case

Hello everyone,

I noticed an issue with the Power Chart tag, I’m trying to parse the selected tag path (selected via Tag Browser) from props.

getChild(“PowerChart”).props.pens[0].data.source

I noticed the path is all lowercase, which doesn’t work well with my script since system.tag.queryTagHistory is case sensitive in perspective scripts. (somehow it’s not in the script console)

histprov:default_db:/drv:test1:default:/tag:ssvs/cameras/camera mode

The actual path is actually:

[default]SSVs/Cameras/Camera Mode

so when I use it with queryTagHistory, it doesn’t work with it being lower case. When I correct the cases, it’ll magically work again.

Again, suprisingly with the script console, case doesn’t matter, doesn’t even need the tag provider. Not sure why.

So the main question is, is there a way to get the tag path from the Power Chart with the correct case? Or must I correct the path everytime?

Thanks

version? there was a recent change to this, idk what it was tho
image

1 Like

Hi, so I’m on 8.1.10, and I came across this too, I looked at the change log but I’m not sure if it’s refering to my issue (see below). I can’t update my gateway right now since there some inhouse protocol to that and I’m not in charge…

Are you on 8.1.14? can you see if the tag source is all lowercase on your end? :grin:
Cheers ^^

This is not a matter of lower/upper case.
I think this path histprov:default_db:/drv:test1:default:/tag:ssvs/cameras/camera mode is incorrect somewhere.

If you use this path in lower case I bet it will still work

[default]SSVs/Cameras/Camera Mode

Proving the historical path is not case sensitive

No it doesn’t work in perspective scripts, I’ve tried multiple times

dataSet = system.tag.queryTagHistory(paths= [‘ssvs/cameras/camera mode’] …) #bad
dataSet = system.tag.queryTagHistory(paths= [‘SSVs/Cameras/Camera Mode’] …) #good

However both will work with the script console, just not in perspective scripts

Are you sure it is case-sensitivity? Instead of failing to include the tag provider? As required in gateway scope?

2 Likes

Hi, sorry the the late reply, we were updating to 8.1.14 and we no longer have the problem. But to answer your question on our end we did had the tag provider in the path. Since I can’t reproduce the problem anymore I’ll say the problem is solved :slight_smile:

Cheers all