Ignition throwing "Error_Configuration" when setting up Modbus tags

I’m trying to set up Ignition to poll values from a Modbus server, but for some reason when I configure the tags in Designer it keeps throwing “Error_Configuration” and returning “Error_Configuration(“Bad_NodeIdUnknown: The node id refers to a node that does not exist in the server address space.”)” for the Quality indicator. I’m confused, however, because I’ve done exactly this process already in Ignition Edge and had no issues. I even cloned the JSON tag definitions from the successful Ignition Edge install and pasted them into this new project, but still no luck. And the Ignition Gateway doesn’t appear to be having any issues connecting to the Modbus server itself.

Here’s a screenshot of the error screen I see in Designer:

Here’s a screenshot of the gateway status for the relevant Modbus device:

Weird. Any accidental spaces in or at the end of the device name or OPC Item Path?

Is the endpoint URL for the “Ignition OPC UA Server” connection definitely pointed at localhost and not some other server that doesn’t have this device configured?

This may seem like a weird question but have you tried setting the OpcItemPath one by one?

I’m getting a similar issue that happens if i attempt to set multiple tags at once. This happens even when the path is correct and predefined in the UDT.

I am also seeing this on a chart recorder I am attempting to connect to with modbus TCP, the instrument also shows as being connected in devices page.

I have tried many variations of registers from the HA028910ENG_16_6100A_6180A_Graphic_Recorder_User_Guide

Integer
Ignition OPC-UA Server
Address like [Boiler]1.951

That’s not a valid Modbus address for Ignition’s driver.

https://docs.inductiveautomation.com/display/DOC81/Modbus+Addressing

I found the correct addresses. No problems now.