Ignition to SQL on separate VM's Troubleshooting

I have an issue where I cannot get ignition to communicate with SQL. They are on separate VM’s on same server.

I’ve tried all examples I could find online. Any suggestions on what I could do that I haven’t done yet?

There’s some pretty smart people here but I don’t think any of us can read your mind.

What have you tried? What’s the error message?

1 Like

Which flavour of SQL?

E.g. MySQL by default only allows connections from LocalHost, MsSQL server has a roles feature for saying which users/from where can connect to the instance/schemas.

Some hypervisors have a default networking type that blocks guest-to-guest traffic. Have you made any connection or even pings from one VM to the other?

Your Right! I started this to see general ideas. I can ping VM, I’ve gone into properties on MSSQL and changed authentications. I’ve tried to recofig database in ignition for the MSSQL. no connection to database.

I am using MSSQL on a separate VM

I have been able to ping the other VM and I can RDP to my sql VM from the ignition VM.

I’ll look into the default networking type in the Hyper V to see if guest to guest is blocked.

What is the error you are getting?
What version of MSSQL? Express LocalDB, for example, does not allow TCP/IP connections.

3 Likes

Also probably worth making sure that Windows Firewall (where MSSQL is running) has a rule to allow incoming connections on ports 1433/tcp and 1434/udp.

“connection Error username failed to connect.” Fails if I have an actual user connected and if I do not create a user or password.

what about using sql management studio to connect from the ignition machine to the sql machine using the credentials you setup for ignition?

2 Likes

Yes, I’ve tried using SQL management studio and tried to match credentials but I am still not getting the database table created in SQL Management studio and ignition gateway is still saying faulted and not connected. This is why I feel stuck because I feel there is some small detail I am missing but I will try all things suggested in the thread.

These are potentially different problems. What do you mean by not getting the “database table created”?

Does the Ignition User have permissions on the Database to create tables? (that would not explain the driver not being able to connect).

When you used SSMS to connect with the credentials for the Ignition User did it successfully connect? Sorry, just “tried” allong with the follwoing statement doesn’t sound like it was successful.

1 Like

Solution: I under she SQL authentication. I needed the same user and password. I also needed to go into SSMS and go to login or users tab and change password for my login to match logic in my ignition gateway.

Thanks everyone fore giving me ideas on what to try!!