Ignition Vision Tag Write Error after Making AB PLC Edit

One of our customers is currently running a vision project on 8.1.18 communicating with an AB L74 on V24. Whenever we make a PLC edit we are running into an issue where tag writes from the Ignition app fail for about a 30-60 seconds after making the edit. Sometimes the tag writes will popup an error stating (“Bad_NotWritable: The access level does not allow writing to the Node.”). But again, we just wait a minute and everything works fine. Has anyone else ran into this issue? Is there improvement with 8.1.19? Or is there anything else I can try to fix this?

image

8.1.20 contains a fix that may be what you’re seeing:

Fixed an issue where Logix writes could sometimes fail if it occurs immediately after a re-browse.

A re-browse occurs any time the program is edited or downloaded.

This appears to be the issue we are having. We’ll upgrade to 8.1.20 and go from there. Thanks for the quick reply Kevin!

We upgraded to version 8.1.20 RC1, but are still seeing this issue when PLC edits are made. Any other idea’s for things we can try to resolve this?

Is it the same error and StatusCode or something else?

I did some more testing, and we aren’t getting the error anymore, and there appears to be improvement, but tag writes are still unresponsive for about 15 seconds from the clients after a PLC edit is made. At this rate, it’s a bit more manageable but still not ideal. I am testing it by toggling a valve manual off and back to automatic, which basically sets an integer value on an opc tag. Immediately after a PLC edit the tag writes are not making it into the PLC when I toggle states, but after waiting 15+ seconds or so they write instantly when I toggle it back and forth.

That’s probably how long it takes to re-browse your device once you’ve make an online edit or download. It’s not possible to read or write during this time.