Image Management tool doesn't worked v.7.5.1

I just upgrade the gateway to 7.5.1 version and when I’m trying to modify/upload any new images, the designer hung. Is there anyone found this the same problem?

Other users have had this problem. It is usually due to users trying to upload an unsupported image. Or, there may be a file you uploaded into a previous version of Ignition that is causing the problem. If you search the forums you should be able to find some more information about it. Some users have deleted images one at a time until the image that is causing the problem is gone.

The image management console hung after I clicked from the menu, and I can’t check the existing images uploaded that may causing the problem as suggested.

Is there anyway to check or finding the resolution of this?

I found the resolution to fixed it from the following link but I don’t know on how to delete unsupported files from gateway.


Could anyone suggest me the steps to remove the files without ‘image management console’?

This can be done by going to the gateway homepage, then configure>system>console. Then select the advanced tab and click the raw settings viewer link. In the list that appears on the right hand side select Image, then scroll back to the top and select execute. This will show you a list of images that are stored in the internal database. You will have to run a delete query for the individual images.

Thank you Greg. The problem was fixed with the following statement of execution.


Glad to hear it worked for you. Were you able to delete the image(s) that were causing the Image Management tool to hang?

I think so but it only one image deleted for GIF file type. After deleted, the image management is working. I still having a question in my head with the cause of this because when I do checking from the manual, files type supported including GIF as well.

What do you think?

There really is no explanation for this. I have tested this here with various different images downloaded from the internet. There may be something wrong with the image that your trying to use, I dont know. Someone had managed to import a .ico (not even supported) into the Image Management Tool, this also slowed the tool down. What was the size of the gif you were using?

I’m not really know for the size of problem’s image.

Can we do this for future enhancement of this tool?
by adding the feature inside Image Management tool, do not link/include the unsupported type or display it as broken link or automatic popup windows when opening the tool with unsupported type found.

The expected behavior of the image management tool is to display an error message when trying to import an unsupported file. GIFs are a supported type, so this issue is strange.

Could you upload the GIF that was giving you problems so we can try it out here?