Imported 7.9.10 gateway but no tags

I imported my working 7.9.10 GATEAY backup but there were zero project tags in the project after import. The client tags were present. The windows were all there too. The gateway connected to my single Siemens PLC. What am I missing ? Upped memory of gateway to 4096 but still same behavior.

I don’t think tags ever came with project exports since they are gateway scoped items. Typically you’d have to use the import/export tool from within the tag browser. See if that works.

1 Like

Gateway tags don’t belong to projects. You have to export/import those separately.

1 Like

Everyone else is correct, also, your memory settings have nothing to do with whether your projects or tags exist.

sorry., mispoke… imported gateway, not project. I know that projects don’t import tags.

I mispoke…I imported the gateway backup file (gwbk), not the project file… any ideas ?

Can you upload your gbwk for us to look at if we send you an upload link?

Yes I can upload file

I’m closing this due to inactivity. If you are still having issues, please let us know.

That’s strange, I was waiting for your reply. I started another ticket on the same isssue and found the bug, I believe.

My apologies, Jim!
I’ll see if I can track down the other ticket you mentioned.

I found the problems. There were two. First when I imported the exported 7.9 tag xml file into version 8.0 gateway it showed me a series of errors in a dialog box. I had data types that were contained inside other data types that no longer had valid data type references (selection box was empty). When child data type did not have a reference version 7.9 was perfectly happy and never threw an error. (The parent data type was also never referenced as a tag). By fixing these problems in 7.9 (looked at error dialog box after 8.0 import) and then re-importing the tags imports worked.

Next, I found a weird bug when I exported my project via the designer (right click export in tree) that many of my windows had duplicates. Also I found that when I clicked on “templates” and tried to export just templates there were windows also selected. This was an older project and had been upgraded several times and copied. My guess the internal database got corrupted. When I recreated my project from scratch importing each section individually (templates, windows, scripts, etc) and making sure none of the duplicates were selected I was then able to import my “fixed” gateway( Both bad tags fixed and offending projects with weird duplicates were removed ) The gateway upgraded to 8.0.0 (released version. However the woes continued… All the parameter references in my child UDT’s did not pass values and the name of the OPC UA server was not correct anymore (7.9 “Ignition OPC-UA Server” 8.0 removed the hyphen “Ignition OPC UA Server” Why I ask ?

1 Like

Bleh, it was changed along with all other references to “OPC-UA”. Didn’t think it would be a big deal because most people should be doing upgrades instead of importing things piecemeal from 7.9, and it’s a simple find/replace before the import if you are.