Impossible to stop this alarm

Hi all,

I’m loosing my mind trying to stop an alarm from coming up. Every second or two for a couple weeks now I’ve been getting an alarm from a tag. Originally the tag was configured with the alarm, but when I noticed that I was getting lots of them I tried the following:
-First I played with the active and clear delay times, but there was no difference. I tried things like setting that the alarm had to be active for thousands of hours, but I still get the alarm every second or so.
-Then I tried renaming the alarm, but the alarm that is coming up never got renamed
-Then I deleted the alarm itself but left the tag, but still go the alarms
-Now I’ve deleted the tag completely, but the alarm is still coming up every couple seconds.

The path to the alarm is being shown as “prov:PMCS_SQLTags_Provider:/tag:KSLNYTRR/Fuel_Level_Alarm:/alm:Fuel Level Alarm” which to me implies that I should look under Tags/KSLNYTRR/Fuel_Level_Alarm. This makes sense, since this is where the tag and alarm were originally configured. But then I deleted the alarm, so “alm:Fuel Level Alarm” no longer exists, and I still get the alarms. And then I deleted the whole tag, but I’m STILL getting the alarms.

I took a huge slap on the wrist and broke down and restarted everything but I’m still getting the problem.

Below I’ve attached a screenshot of the Ignition alarm events table to show the alarm paths, and I’ve included a screenshot of the tag configuration in Designer. The tag used to exist right above “Fuel_Theft_Alarm”.

I’m stumped. The only thing I can think of is that I’m looking in the wrong place for the alarm. Am I misinterpreting the alarm path or something? The only other place I know alarms can come from are from the transaction groups, but I’ve verified that none are configured there (and those have a different “prov:” in the alarm path). I’m also pretty sure I was looking at the right tag, because when I watched it I’d see it go on and off rapidly. What else can I try?


Deleting the tag from Kepserver was able to stop new alarms from coming and allowed me to finally delete all the old alarms without crashing the frontend. If I select too many alarms to acknowledge at once the UI locks up and then returns an error, so I have to acknowledge them in small (a couple thousand at a time) batches.

I restarted the gateway again, and then reopened the designer, and low and behold the tag is back! If I hadn’t posted the screenshot showing that I had deleted it I’d be thinking I was crazy (or had been working in the wrong tag folder). Of note for that screenshot - I didn’t delete the tag and then take the screenshot (ie: possibly not save the changes). I deleted the tag before the holidays, saved, and then yesterday reopened the designer, expanded that folder, then took the screenshot.

I recall having issues with Ignition’s subscriptions to Kepserver tags - I’ve found that if I rename a kepserver tag, the Ignition tags configured with the old names will STILL follow the new tag until I restart the gateway. Could it be that a similar thing was happening - that it was still subscribed even after I deleted the tag in the designer, and this subscription still held the alarm configuration?

I’ve changed the active and delay times to an hour again and it appears to be ‘sticking’ this time. Is there any way to diagnose what was happening? There doesn’t seem to be anything relevant in the logs - maybe IA has somewhere else they can look to troubleshoot these issues?


If you’re still having issues can you post the alarm configuration in a screen shot?

I haven’t had any complaints since the second reboot so I assume all is still well.