In place upgrade from 7.9 to 8.1

Dear all,
we have problem upgrading our Ignition 7.9 to 8.1. This is a test VM to see if all the projects survive the upgrade, hence it is not licensed. Anyway, while upgrade is running, the 2-hour trial takes place. I have tried ordinary tools from my toolbelt (e.g. running installer as an administrator, give proper permissions to folder where Ignition is installed (r/w for everyone during the installation)), yet I don't have any luck.
1
2
3
The problems manifest themselves with what the screenshots show.
install_20230622-1600.log (13.8 KB)

Log from the installer is also attached. I have read through the log, but I am not finding anything moving me forward. Thank you in advance.

java.nio.file.FileSystemException: C:\Program Files\Inductive Automation\Ignition\lib\catapult.jar -> C:\Users\adm.xyz\AppData\Local\Temp\11_ignition_preinstall_temp12179683200774121723\lib\catapult.jar: The process cannot access the file because it is being used by another process.

Overzealous security software, perhaps? A random .jar file in a temp directory should absolutely not be 'in use' by anything besides Ignition itself. Talk to your IT department.

1 Like

Thank you for blazingly fast feedback!

AFAIK we don't have applocker on servers, I'll chase IT department nevertheless (it could be different form of protection).

Thank you!

I ran into the same issue when upgrading from 7.9 to 8.1.

I ended up just taking a backup, uninstalling 7.9, installing 8.1 and restoring the backup.

The only "security" software on this host is "CrowdStrike Falcon Sensor". Maybe you have that or a similar piece of software installed.

2 Likes

Hello all, the main reason was that the administrator installing the 8.1 had Gateway launcher utility running as I have learned afterwards. Hence the installer could not touch this file. Terminating the process of gateway utility has solved the problem. I hope this helps to others having similar problems.

2 Likes