Increase amount of connections

Hi all,

In my project I wrote a bunch of new queries. After I wrote those query’s the connection with the database sometimes will fail. The error I get is " Connection Pool Exception: Cannot get a connection, pool error Timeout waiting for idle object".
I think I get this error because the connection pool is out of connections. Is there any way to increase the maximum amount of connections?

See the picture below for more information.

image

Thanks in advance

That would be a setting in the database. Without knowing what database you are using, that is as far as I can go.

Sorry, Just noticed your max connection is set to 8. If you go to the settings of the database connection in the gateway, the max/min/idle connections numbers are under advanced settings. It may still be worth looking at the pool size in the database at some point, though.

2 Likes

Also worthwhile to see if you have transactions you aren’t closing (or are keeping open a long time). They will hang on to connections until the timeout, which will decrease your available connections.

1 Like

Thanks Jordan,

This was indeed the answer I was looking for. Since I increased the maximum amount of connections the database connections haven’t failed anymore. Despite I think it is a good idea to check the prestation of my query’s.