Increasing designer max memory

Hello!
Yesterday i was speaking with Paul Scott by skype and asking him about max value of memory in designer.
He told me to change it in Gateway settings and restart the designer.
But it is not helpful.

screenshot.su/show.php?img=05723 … a00ce2.jpg

How is this not helpful? He answered your question with an exact answer.

Serhii,

Did you save the changes to the Gateway settings before restarting the designer?

Yes, i saved the settings.

Week ago i installed the Ignition 7.7.1 on my local PC and have same issue. My maximum memory in designer dont want to increase.

You should also verify that you don’t have a JAVA_OPTIONS system environment variable that is set to “-Xmx512MB”. This would override any other memory setting in any other location.

I love you Kyle.

I dont have this variable in my system variables.

Hello? Need answer!

Hi Serhii

We all want answers, but you understand that this is a forum and is not part of any official support structure. If you need specific help that is urgent then call or email support directly. Most people here like myself are other integrators, some of whom take time to help others.
I can assure you that

will not produce the results you are looking for.

1 Like

To be honest, this sounds like something in your local settings. I’ve tried this with 3 different Ignition installations, and six different machines running designer. I cannot replicate this.

Start with:javaws -uninstalland remove whatever local cache items you have. Note: this will also remove whatever icons you have on your desktop created by WebStart, so they’ll have to be recreated.

See If that helps.

I dont have this variable in my system variables.[/quote]
Perhaps you could try putting one in, using -Xmx1024m to set your max heap size. If that doesn’t work, you can always pull it back out.

[quote]I can assure you that
Quote:
Hello? Need answer!

will not produce the results you are looking for.[/quote]

Unless Jordan is around, who is amazingly generous with his time.

He must either work for himself or has trained his boss very well. :laughing:

Nah. I got upgrades going on. :mrgreen: I can squeeze that stuff in and call it stress testing… :laughing:

If the new memory setting is not taking when you launch the designer then close all open clients and designers on this machine and clear the .ignition cache (delete the .ignition folder and its contents) on the computer you are working with.

1 Like

It is helpful, thanks :thumb_right: