Install error "Unable to extract install into 'C:program files\Inductive Automation\Ignition': java.lang.runtimeException:java.io.FileNotFoundException:

Windows 10 Enterprise version 1809 17763.1697 x64 operating system

I get the following two errors when trying to install ignition on my computer.
Snag_50a4c6

I am a “Flex” user with rights to install software. I worked with our IT department and they get the same error and they have complete admin rights.

2 Likes

I am having a similar error when trying to update from 8.1.3 to 8.1.11. Did you find a solution to this error ambaker92?

The only solution that I found was installing the software onto a VM. If you are using yours as a production machine I do not see this as a viable solution for you.

ambaker92,

So I had version 8.1.3 installed on a windows 7 VM. I tried to upgrade to 8.1.11 for the new perspective features but that’s when I ran into the error “unable to extract Ignition runtime files”.

I may have to create a new VM and go from there.

Update as of 11/1/2021

I was able to finally install version 8.1.11 on Window’s 7 VM by installing to a different folder on the C drive. When running the installer I choose to install to folder “Inductive Automation1” instead of the default “Inductive Automation” folder that I had previously used for 8.1.3

I think the error originated from the fact that I tried to upgrade WITHOUT stopping the Gateway. NOTE to self- Stop the gateway before trying to upgrade.