Installing Ignition 7.2.X


I had downloaded Ignition recently but did not install it yet.

I had a previous version, 7.1.8 and never did the installation either.

tonight I try to make the installation of which failed. I believe that the downloaded file may have been corrupted so I went back to replace the file. The one I attempted was 7.2.1 so I tried the most recent: 7.2.2. I chose the version for Windows 7 64 bits (my computer runs on W7 and 64 bits…just in case one should worry if I got the correct version for my OS).

I get some messages close to the en of the installation which I made print screens and copied them unto MS Paint.

Also I double checked my version of Java. It was easy to verify on SunJava’s web site. Currently I have version 6 update 23.

Hopefully I posted my question in the proper topic.

Thank you for your help.

Is it possible you don’t have administrative permissions? Try right-clicking the installer and choosing “Run as administrator”.


First I removed the non functional software and did the installation as suggested.

I right clicked on the file and ran as the administrator. As it reached the end, just before it created the uninstaller, it gives me those messages.

In the start up menu, all programs I can see the Inductive Automation icon, I click then I can see a “Sub Icon” called Ignition, I click again and there are two items showing: Launch Gateway Control Utility and the Uninstall.

Obviously the Launch Gateway doesn’t start up any thing.

Is it possible that because MySQL is running that I get this message?

Thank you again.

Do you have any 32bit JREs installed?



Sorry it seems like I don’t get the abbreviation.

Should I stop the Antivirus? I use Kaskersky.

Thank youl

Any 32bit Java Runtime Environments installed?

With my Chrome browser I made a search with Java Runtime Environments.

I ended on CNET’s download website. I did the download. I got the message: this program is already installed. I went ahead any way and replaced the software. It is the 32 bits (jre-6u23-windows-i586).

I tried again to open up Launch Gateway Utility. But it failed again (but I didn’t do a re-installation of Ignition).

As a note: I had installed Factory PMI but I had not tried it. I removed it before installing Ignition.

What should I do next?

Is java in your PATH environment variable? (If you go to the command prompt and type “java”, does it recognize the command? ) By default, Ignition expects java to be defined in your path. You can also explicitly state the path to the java command in the wrapper.conf file. I once had a system that wouldn’t start after an install (just like for you, installed successfully, but failed at the end when starting the service), and after checking all kinds of system settings to no avail, it ended up being as simple as that.

Good luck!


Hello Dan,

So what I just did is go to “Run” and typed “Java” The command is not recognized.

Now you have to forgive my lack of knowledge. This is not my specialty. I would obviously expect just to go smoothly.

How would I force the path? Where do I find the wrapper config file? Can you provide more informations on the steps?

Thank you.


The “path” in windows is a setting that tells the system how to find things- so, when you type “java” on the command line, and it says “not found”, it means that the location where java is installed isn’t on the windows “path”.

We also would like things to go smoothly, but sometimes various things work against us. When our installer detects that java is missing, it installs it and puts it on the path. In your case, though, java is already installed- it just wasn’t put on the path (we’ve seen this in various cases). Ignition depends on java being on the path by default, because we can’t know where every user will have Java installed.

Not to fear, though, as it’s easy enough to change:

  1. First, track down where java is installed. It should be somewhere like [tt]C:\Program Files\Java\jre[version number][/tt]
    Since you’re using 64-bit, make sure it’s under “Program Files” and not “Program Files (x86)”.
  2. Under that folder you’ll have a “bin” folder. This is where all the java programs are. Copy the full path to that folder.
  3. Now locate the Ignition install directory. It will be in “Program Files\Inductive Automation\Ignition”. In might be in the “Program Files (x86)” folder, but don’t worry about that.
  4. In the Ignition install directory, there is a file called “Ignition.conf”. Open that with notepad.
  5. Towards the top you’ll see: [tt][/tt]
    Change it to have the full path in there: [tt]\Program Files\Java\jre[version]\bin\java[/tt]

Now go to Services under Administration tools (Start>Control Panel>Administration Tools>Services). Find Ignition and start it. You should now be up and running. Once the service starts you can open a web browser and point it to [tt]http://localhost:8088[/tt]

Hope this helps, let me know if anything is not clear.



I checked this “Detail”. Here is the path: C:\Program Files (x86)\Java\jre6\bin.

So it’s in the wrong Program files. This means that I should uninstall Java and re-install it in the correct folder. Will this be an issue for my other programs that “Know” the path?


I checked this “Detail”. Here is the path: C:\Program Files (x86)\Java\jre6\bin.

So it’s in the wrong Program files. This means that I should uninstall Java and re-install it in the correct folder. Will this be an issue for my other programs that “Know” the path?[/quote]

It was likely installed in that folder because it was the 32-bit version of Java. You shouldn’t re-install the same one and force it to another folder – you should make sure and install the 64-bit version of Java.

As suggested I installed the Java 64 bits. It automatically selected the proper folder. C:\Program Files\Java\jre6.

Next I went to the Ignition folder in the Program files. There is a Ignition item but there is no .conf all together. The type of file is CONF file. I tried to open it but Windows couldn’t and offered the choice of software to open it up, I chose NotePad. There was a long single paragraph.

I found “ and not:”(it’s late so my eyes my be playing tricks on me). I still tried to and it ended as:\Program Files\Java\jre6\bin\java#

When I try to same I get the message like what I cannot save in that folder. I renamed it by adding a 1 simply to recognized it.

Is it because I’m not as an administrator that I can’t. I’m proud I went this far… :open_mouth:

I also ran the CMD and tried java again; this time I ended up having a long list of information on Java. This means that I went somewhere with this new installation of JAVA64 bits.

I’m almost there, help again please!!!

Thank you.
ignition1.txt (8.35 KB)

Well, if you get the java info to display when you type “java” from the command prompt, it means java is in your path. Since the correct java may now be in your path, will the service now start as-is with the original wrapper.conf file (the one with

Regarding being unable to overwrite the wrapper.conf file, are you running as the same user that installed Ignition? I’m not certain of the permissions on those files, but if the admin account installed it, you may need to be admin to change the files. If you can get the privileges to overwrite the wrapper.conf file with the full path to java, make sure you change it from\Program Files\Java\jre[version]\bin\java
(which is in the file you attached)

to\Program Files\Java\jre6\bin\java


Hello Dan.

I’m the only user on this computer. I’m always as the administrator.

Now since Java is in the path, if I cannot overwrite, should I simply uninstall and re-install.

In the start menu, under all programs I have the icon for Inductive Automation. I click it and then I can see a folder like icon as Ignition. There are only two possibilities: Launch Gateway Control Utility and Uninstall. Shouldn’t there be more?


After adding java to the path, you shouldn’t need to re-install. You only need to edit the wrapper.conf file if java is not in the path. Launch Gateway Control Utility and Uninstall will be the only two items in the start menu folder. What happens if you try to launch the Gateway Control Utility?


I tried to open Ignition Gateway with the right button and to run it as administrator. The gateway didn’t open up. Again I tried to replace the CONF file with the same barrier to proceed.

I decided to remove it. What do I have to loose?

During installation I didn’t get the same message for the error.

In the start up menu I got all the way to Launch Ignition Gateway…and now I’m in business.

At least now I can say that I lost my Ignition Virginity!!! Finally at 46!!!

Thank for the support of all you gentlemen. Hopefully this topic will help others just like me.