IntelliJ and OpenJDK 9 : Failed to deploying to http://localhost:8088

After reading “The Real Deal About Java and the future of Ignition” I swap my javaJDK from Oracle JDK 8 to OpenJDK 9.

Ignition Gateway doesn’t start with this option :

wrapper.java.additional.8=-Xrunjdwp:transport=dt_socket,server=y,suspend=n,address=8000 # autorise un remote debug sous le port 8000

logs :

ERROR: transport error 202: bind failed: Can’t assign requested address
INFO | jvm 1 | 2018/05/10 05:33:15 | ERROR: JDWP Transport dt_socket failed to initialize, TRANSPORT_INIT(510)
INFO | jvm 1 | 2018/05/10 05:33:15 | JDWP exit error AGENT_ERROR_TRANSPORT_INIT(197): No transports initialized [debugInit.c:730]
STATUS | wrapper | 2018/05/10 05:33:20 | Reloading Wrapper configuration…

by removing this option, gateway starts without trouble.

IntelliJ isn’t enable to deploying module : timeout. However, module can be load without trouble from gateway web interface.

My wrapper conf is :

wrapper.java.additional.1=-XX:+UseConcMarkSweepGC
wrapper.java.additional.2=-XX:+CMSClassUnloadingEnabled
wrapper.java.additional.3=-Ddata.dir=data
wrapper.java.additional.4=-Dorg.apache.catalina.loader.WebappClassLoader.ENABLE_CLEAR_REFERENCES=false
wrapper.java.additional.5=-Dignition.allowunsignedmodules=true # autorise les modules non signés
wrapper.java.additional.6=-Dia.developer.moduleupload=true # autorise le chargement des modules directement par Maven
wrapper.java.additional.7=-Xdebug # active le mode debug
wrapper.java.additional.8=-Xrunjdwp:transport=dt_socket,server=y,suspend=n,address=8000 # autorise un remote debug sous le port 8000

Any idea?

Best

1 Like

Is it the same with OpenJDK 8?

Also, it seems that address now expects a hostname:port rather than just a port. Try something like address=localhost:8000.

Thank for your reply, no more success with localhost:8000

I’ll try with OpenJDK 8 tomorrow

This bit is also suspicious… like maybe you already have something bound to 8000, intentional or not.