Interacting with desktop

Please help! I’m having trouble and starting to think it’s just not possible with Windows 10!
I’m trying to execute programs on my desktop (maker server installed on my laptop). It woks in the designer since I’m running the designer as my user but the Ignition Gateway is a windows service.

All I’m trying to do is open programs via .bat or .exe
When I try the same script from a Perspective application the programs are showing up as Background Processes in my task manager.

I tried changing the service to Log On with my user and password with no difference.
I also tried using the Local System with “Allow service to interact with desktop”. No difference.

I was so excited to use Maker for this application but now is my idea out the window?!

Thanks for any help.

There are options to allow a service to interact with the desktop and run as a particular user. Not recommended, generally, as it doesn’t scale, and doesn’t work at all when no-one is logged in. And naturally, a perspective session connected from another PC would cause the app to run in the server, not locally. And this has been true since Windows NT–it isn’t a new thing in Windows 10.

Clients running the Vision module could do this, but Vision is not offered in Maker edition. Perspective Workstation might have some options along these lines in the future, but I wouldn’t hold my breath waiting on them. Browser-based apps are natrually constrained to the browser user interface by the security model.

Thanks for responding. I’m interested in other options to allow the ignition gateway server to interact with the desktop. FYI, this application will only be launched on the gateway server (it will not be scaled nor will it have a remote clients connect to this server). I know I can go other routes to develop an GUI program but I would MUCH rather develop my local app using Ignition.

I tried going the run as route when executing the .bat file but I was having problems with the password prompt. I tried using /savecred and exeucuted the script using the same user as the Log As user for the ignition service but still would launch the programs in the background process.

My understanding is that this isn’t possible since Windows 7. Even when you change the user the service runs as and check “allow interaction with desktop” it still runs in session 0 where it will not be seen. These changes simply allow the process to be started without failing so that legacy applications relying on the behavior don’t crash.

Learned something new today. Can you tell how long its been since I’ve deployed Windows as a server?

1 Like

Well this is all just if you believe a thing written by a guy on the interwebs. I don’t know this firsthand.

Well this makes me sick to my stomach :face_vomiting:.
Thanks for the help guys. Back to drawing board. Besides this unfortunate event, Maker has been incredible.
Until the next time. Cheers!