"Invisible" items shown for a split second after opening popup

When I click on a item that opens a popup from a script in a session, I'm seeing items that should have a display position value of 'false' for a split second.


After that split second, everything goes to how it should be:

How can I improve this? Is there a way to artificially delay the popup open time by 250ms while it loads before anything is displayed? Open to suggestions with any solution.

Save the view in designer with everything already set to Visible False.

1 Like

I am currently doing that and it still has this behavior :\

Is there any chance your bindings are executing twice? Once with the default values of all props, and again after async bindings complete? You may need to check that all of your "as saved" properties, involved in the visibility bindings, produce a "false", too.

Yep any view/property that could be affecting it has an "as saved" value of false. Of note, this is true for literally all of my popups *and pages, there is an initial 250ms of loading where all bindings have yet to initialize

Looks like the same thing is even happening with the Ignition demo screens:
Perspective Demo (inductiveautomation.com)

Is it possible to load a view/page/popup but not display it for a predefined delay period?

1 Like

I assume one component you are referring to is the alarm banner? If this is similar to the exchange resource, it has a binding for display. Create a startup script on the root container and set display to False. Do this for all items you don't want to show briefly.

I'll give that a shot, thanks!

You may also try setting Persistent option on the binding. I noticed similar behavior as you when using the enabled property for components. Setting Persistent worked for me. Just remember to save the view in the "correct" state.




Didn't completely get rid of the issue but it did actually help quite a lot. Seems so obvious in hindsight but for some reason I didn't think to mess with the persistent property