io.netty.channel.AbstractChannel AnnotatedConnectException

Hey guys

i’m trying to create an opc ua server but i 've this message /
UaException: status=Bad_ConnectionRejected, message=io.netty.channel.AbstractChannel$AnnotatedConnectException,

after long and long test , turn off fire wall , instaling latest version of java and make it autorized by fire wall , nothing work after that ,

pls help

What server are you trying to connect to? Is it running on another machine or the same machine? Are you sure it’s actually running and you have the right hostname and port?

The error you’re getting is just a standard TCP connection error: connection refused. If not a firewall issue this usually means there’s just not anything actually listening at that address/port.

it’s same machine (my laptop) and for the port is by default is 62541

So you’re trying to create another connection to Ignition’s own OPC UA server then?

Try using “localhost” in the endpoint URL instead of “192.168.0.24”.

yes i’ve tried that before and it’s going to the next steps buuut in thi end i had satut FAULTED .

is same when i use 127.0.0.1 like localhost .

If it’s the same error message even when using localhost then maybe the server is failing to bind on startup. You might want to get in touch with support so they can take a look at an export of your logs.

thank you !!!