iOS6 on Iphone 4s not working properly with mobile module

#1

We have discovered that after upgrading our Iphone 4s’ to Ios6 last week that we can no longer create a home screen icon to log in to our mobile module projects. It gives an Error (error): 500 Internal server error. We did not have this issue with Ios5. Only way we can get to the projects is to physically type the address into safari and log in. We have tried this on 3 I phone 4s’ and they use different carriers. And accept cookies always is turned on…I don’t know what changed, but this has become an issue for us…any advice would be helpful.

0 Likes

#2

I have Ios6 on my phone and it works just fine for me. I can add icons to the home screen.

0 Likes

#3

We can add the icons, but it when we type in the user name and password it gives the internal server error. My boss said he could not log in on his Iphone 4S anymore with the icons and we checked his phone and he said he had upgraded to ios6. Well i used my Iphone 4S that still had ios5 and it worked fine so i upgraded to ios6 and then my icons to the mobile module would take me to the login screen but after submitting user name and password it gave me the same internal error 500 that his phone did.

0 Likes

#4

You are right. I get the same error as well. It only happens when it has been added to the home screen. I will have our developers look into it. Thanks for the update.

0 Likes

#5

Seems like the way Safari is caching now that is causing the problems in ios6…

http://arstechnica.com/apple/2012/09/developers-claim-safari-in-ios-6-breaks-web-apps-with-aggressive-caching/

Already have had quite a few customers calling me saying their ipads and iphones are not working anymore…I ask…did you upgrade to IOS6? And all of them have said yes…seems like this is gonna be a headache…don’t really want every customer to download Dolphin and make their log in page their home page to access their project. :confused:

0 Likes

#6

We have made a ticket internally to get this issue resolved. Once there is a fix we will post here.

0 Likes

#7

We’ve got this issue fixed. I have a few more polishes to do on the fix, but I’ll upload a beta version of the mobile module tomorrow to this thread so you can get the fix.

0 Likes

#8

Ok, try this version of the mobile module.
Mobile-module.modl (479 KB)

0 Likes