IP camera viewer problem


I’m testing the IP camera viewer with Foscam FI8904W camera. In the camera documentation is stated that camera supports 4 simultaneous connections to stream video. Ok, I tried that with 4 browsers open and I can see all 4 video streams.

When I use IP camera viewer in Igniton with url of the camera, the picture/videostream is showing. Ok. When I run the Ignition/Vision client, the camera picture/stream is showing.
But… when I run second client, or third, or fourth client, these clients don’t show the live video.

When I look in Ignition console:

When I look in the browser, I get:

It seems, that IP camera viewer is using more than one connection… or not?

The second thing is, that when I run Ignition client from another site, like my office, the IP camera viewer will not connect to the camera, because my office network is different, than the plant network
http://www.inductiveautomation.com/forum/viewtopic.php?f=72&t=5744. I used urlproxy, like Carl suggested in that post, but the I get:

Also in browser I get:

I know that is happening, because there is no user and password in the url and camera requires one. But How can I pass parameter inside the parameter? When I do this: … pwd=user12

I get the same unauthorised message:

Any ideas?

That URL is not a MJPG stream url. We only support MJPG stream or JPG stills. Usually the url has something like this:

or something like that.

Ok, now I’m confused… :confused:

What you mean by ‘That URL is not a MJPG stream url’?

If it’s not, how that I can see video in first client that runs? Every client that runs later, they can’t see it.
This camera has only mjpeg…

I put camera online, so you can test it. Our upload is not so good, so framerates are low.
If you open four browsers (or four tabs, I’m testing this in Chrome and Safari, in Opera, Firefox and IE doesn’t work) with this links, you can see all four streams.

But when you run four Ignition clients, only the first one will get the video, and other don’t…


Because here is night time, you can’t really see nothing usable. I made a mistake and put the camera behind the window in my office at work, and all you can see is reflection of IR LED in the glass, because there is a strong light outside the front entrance of our offices.

You can also try this link in browser and see the page source: http://bl0610.myfoscam.org:3214/live.htm with user12 as user and password…

Sorry I didn’t realize you could see the first one. I read a little to quick. :wink: I see what is going on now. Can you open the first client with the IP camera viewer and inspect the camera to see how many opened connections there are? We should only open up one connection.

You might try the latest 7.5.7 beta… Carl just fixed a bug where multiple connection attempts to the camera were being made unnecessarily.

I just tried 7.5.7 beta and now it’s working. :smiley:
I can run 4 clients and all four are seeing the video stream.
Thank you @Kevin.Herron. :prayer:

Now, about my second issue:
If I run clients from the same network where the camera is, then I can see video. But if I run client from from my office (which is in another country), I can’t see the video.
I tried the urlproxy but I always get unauthorized (last three pictures in my first post), because I can’t (or I don’t know how) pass user and pwd with proxy url…
To put the camera online (on the internet, outside the factory) isn’t the option. Only Ignition gateway can be accessible from the internet.



you have to URL-Encode the parameters.


i can see a nice picture from your cam (your fence looks a bit damaged :wink: ).

A side node: I recommend to change your gateways admin password before publishing the ip in a forum :smiling_imp:

Thank you @Chi. :prayer:
It’s working. :thumb_left:

At first I’ve put this string to URL property of IP Camera viewer: … pwd=user12

and disabled Use Authentication? property of IP Camera viewer. I don’t need it if I pass user and pwd in url, right?
And I got ‘IOException: Stream is not an MJPEG stream’. No video in the IP Camera viewer.

Then I enabled Use Authentication? property of IP Camera viewer and leave the URL string the same and … voila… camera viewer is showing the video.
Now I don’t really understand, why must Use Authentication? property of IP Camera viewer be enabled, if I pass the user and pwd with URL string, but… it’s working. :confused:

What I’ve noticed is, that now camera viewer is not showing the video every time, when I open the window with viewer on it. I must open another window in client then open the camera window again and it’ll show the video. Sometimes it takes just one try, sometimes I have to do it more times…

I think it would be useful, if the IP Camera viewer would have the possibility to Refresh the connection (or something similar)…
Or maybe it have, but I didn’t found it yet? :blush:

I believe you can “refresh” the ip camera through scripting by setting the URL first to empty string and then setting it back to the actual URL. Try that and see if it gives you the results you want.

Thank you, Dave, it’s working. I’m satisfied for now… :slight_smile: