Is there any way to stop a project from minimizing?

When I try and print from a web page and the print dialog comes up it minimizes my project … any way to stop that ?


I’m not quite getting the picture of what you’re describing, can you elaborate please?


there are a couple of things which cause the entire project to minimize to the task bar.

Scenario #1 is if I use the IE ActiveX component to load an internal website which uses IIS and SQL Reporting services and contains all the security features required for our standard reporting package. I create a window and place the AX component on it and it loads find when I call the window within the application. It’s extremely difficult to log in to the web interface because for some reason the cursor won’t focus on the input box unless you hold the left mouse button down and type in the box … seems like you have to get it just right before it will focus on the input box properly … once logged in I can navigate the website fine and then go to the reports area … pull up a report and use reporting services built in print function which is ALSO an activeX component … when print is pushed the entire project is minimized to the taskbar and the print dialog which is where you can specify a printer and hit OK Just like if you hit control-P on a word doc or any doc for that matter. Once the job prints you have to click on the minimized project to bring it back full screen …

I’ve tried making the entire project touchscreen enabled … still occurs.

Scenario #2 This also occurs when I use the print function which is part of the Alarm History example … there is a difference however in that the rpint dialog stays inside the project and an order to print you must click the minimized project just to get to the print dialog which looks like it’s being properly loaded from FPMI inside the project.

I know I added the onfocus issue here for login as well which is frustrating the users to no end.



I’m not 100% sure I know what is going on, but this is my guess:

This project is loaded in full-screen, yes? Full screen mode doesn’t like when things pop up external windows. From a technical sense, in Windows, only one window at a time can be in FSE (full screen exclusive) mode. If that window opens any popup window (such as a print dialog) the FSE mode is broken, and the full screen window may minimize. We have gone through great pains to make sure that FactoryPMI itself never opens any true popup windows when in FSE mode: all error, confirm, info, and print dialog boxes are actually painted within the main window on a higher plane. Mixing ActiveX and FSE mode is a dicey proposition, as ActiveX components paint on the very highest plane possible, above our popups. Worse, their print dialog boxes don’t follow the same rules as ours, opening a heavyweight print dialog box that breaks FSE mode.

I’m not sure that there are very graceful solutions for you besides: 1) Don’t use FSE mode, or 2) don’t use the ActiveX browser.

I haven’t a clue about the focus issue, which I agree, sounds infuriating. Is there any javascript on that page re: the login field?