Issue Launching Designer

Hi All,

I’m new to Ignition. I’m suppose to learn Ignition and develop Ignition applications for a company who already have Ignition. I managed to log in to my client company’s gateway and launch designer. I didn’t obviously want to write any test apps in the production environment so I installed a local trial version for my learning activities. However, after installing the local version, I can’t launch the production version designer. Any help would be greatly appreciated.

P.S I uninstalled my local Ignition trial version but I still can’t launch the production version Designer from the gateway.

Best Regards

Most likely the designer is set to use more than 1.5gb of memory. You are probably running java 32 bit.
Uninstall java 32 bit and install 64 bit.

1 Like

Thanks a lot for the reply. In fact I have a 32 bit OS so java too is 32 bit.

Is it correct to say that 1.5gb memory setting matters if both designers were launch at the same time? If that is the case, I’m not trying to launch both designers at the same time. I want to launch one designer at a time. The local version designer runs but the production version seems to crash ( few seconds after Java logo shows up).

Best Regards

Designer memory is set globally for the gateway, so if you use any 64bit designers with more that 1G of memory, you’ll have to have all designers be 64bit.

1 Like

Just a while ago I uninstalled the local trial version Ignition and tried to launch the production version designer by logging in to production version gateway. But still the production version designer doesn’t launch.

@pturmel, thanks for the reply. I’m completely new to Ignition. So please bear with my questions.
Does this mean I cannot launch 64 bit production version designer when I have a 32 bit Ignition trial version installed on my machine? As I mentioned I uninstalled the trial version and it seems some configuration still remains in my machine that affect the production version designer.

No, it means the 32-bit version may (probably) won’t launch.

1 Like

Well, in my case it is the 64 bit version hosted elsewhere that doesn’t launch. The 32 bit trial version hosted on my machine works fine. To me it looks like the local installation interferes the production version and uninstalling the local verion doesn’t clean all the settings.

Hi Everyone,

Finally I managed to fix the issue with the help of support team. Support team suggested to clear ingition and java cache. And it worked!

Here is the link: https://support.inductiveautomation.com/index.php?/Knowledgebase/Article/View/112/0/how-to-clear-client-ignition-cache-and-java-cache

Thanks all for your responses.

Best Regards,
Shanaka