Issue with java.net module import in Ignition V 8.1.5

Used Module “java.net” for InetAddress for pinging the IP address from the Ignition installed PC. Was working well for ignition version 8.0.16. But, after upgradation facing problem/error for new version 8.1.5.
Tried both upgradation and fresh installation of the version 8.1.5

What is the error? Can you post a stack trace?

1 Like

from java.net import InetAddress
timeout = 5000
device = InetAddress.getByName(address)
ping = device.isReachable(timeout)
if ping == 1:
Print “Device Reachable”
if ping == 0:
print “Device is not Reachable”

As a Output of this script is “Device is not Reachable”. without any error means, its not able to ping the IP address which is connected.
I read below doc and found some details related to the firewall and server configuration blocking.


URL -InetAddress (Java Platform SE 8 )

If on Linux and not running as root, use of any ping-like raw packet requires the CAP_NET_RAW capability (privilege). You can specify that in the SystemD service file (or override) with the AmbientCapabilities=CAP_NET_RAW setting. You can specify multiple capabilities with whitespace. I recommend AmbientCapabilities=CAP_NET_BIND_SERVICE CAP_NET_RAW.

I run a script that is essentially the same and it works just fine, never broke with upgrades. (1.8.16)