Issue with Property Tag Binding

Good Morning,

I’m running Perspective on 8.0.16. I have what appears to be a clear-cut bug. I’m hoping I’m just missing something stupid…

When I bind a tag to a Text Field’s text property, the Direct binding works fine:

When I bind to the same tag as an Expression binding, the tag gives a Bad_NotFound error.

To troubleshoot, I’ve also tried Memory tags, different tag providers, different Gateways, and restarted my Gateway. Same result.

Thanks in advance for any thoughts.

What you need here is the tag() function:
Wrap tag() around your line and change the { } to " ".

tag('[System]Gateway/Alarming/Active and Acked')

This actually doesn’t work for me in 8.1.0-rc3 (Tag -> Expression)
It does work if the binding type is Expression (not Tag -> Expression)

Thanks for the quick response. I had also tried this approach, with no luck:

You’re right. I edited my previous post.

Using tag() also works for me in the Expression binding section. Given that the Functions menu is provided in the Tag->Expression binding section, this leads me to believe that using tag() there should also be valid.

Additionally, I’d believe that using the {[tag_path]} format in the Tag->Expression section should be valid, since that’s how it’s written when using the Browse Tags menu item.

Expression mode doesn’t work the way you’re expecting it to. The expression given should itself evaluate to a tag path - so "[System]Gateway/SystemName" works - but passing {[System]Gateway/SystemName} is trying to find a tag named whatever your gateway name is - which fails, hence the error.

Think of it as being wrapped in the tag() function - it’s a way to more easily construct a complicated indirect reference - with the benefit that (at least in theory) it can be bidirectional.

Thanks, that makes sense.