Issues loading demo Perspective project

I’m also having the same issue with the demo in Chrome and Safari (both on MacOSX and iOS, have not tried Windows yet). Chrome is up to date. I tried clearing the browser cookies/cache, but no luck. Also, tried loading it over cellular to make sure it was not a firewall issue, but that didn’t do the trick either.

When I view the developer tools for the page I get a couple errors. The first one is “DevTools failed to parse SourceMap: http://demo.inductiveautomation.com/res/perspective/css/PerspectiveClient.css.map”. The second error is “WebSocket connection to ‘ws://demo.inductiveautomation.com/system/pws/OnlineDemo/published/3c3819ad’ failed: Connection closed before receiving a handshake response”. When this second error occurs, the demo cycles back to the “Authenticating” and then back to “Connecting” again (and the error occurs again). Just keeps doing this on an endless loop.

Let me know if there is anything else I can check on my end.

Thanks,
-Will

I was able to get the demo working on my Mac using Chrome by using my phone as a hotspot. I figured this wouldn’t work since I couldn’t get it to load in Chrome on my iPhone, but it looks like that may be a different issue. In Chrome on iOS, when it is trying to load the “Connecting…” display dialog is completely missing from the webpage and just sits there trying open. Figured I’d pass that along in case it helps at all.

Now to see if I can figure out what is blocking the connection on our Sophos UTM…

Looks like I’ve had some progress with accessing the demo. I added some rules to allow for http://demo.inductiveautomation.com/* and ws://demo.inductiveautomation.com/*. This got rid of the handshake response error, but now I’m getting “WebSocket connection to ‘ws://demo.inductiveautomation.com/system/pws/OnlineDemo/published/39adaed1’ failed: Error during WebSocket handshake: ‘Connection’ header value must contain ‘Upgrade’”. Any suggestions? Other links I should add rules for in the firewall?

Will - I moved your posts to a new thread just so hopefully someone with more knowledge about perspective can chime in (I’m on the 7.9 side, so most of this is as new to me as the rest of you).

1 Like

I’m having the same issues loading the demo project from my home network. Works through my cell phone as well as through a VPN service. So must be some conflict in my firewall or ISP?

Can those having issues give a little more info on the type/config of firewall (understandable if not)?

Sounds like something is blocking ws:// and/or wss:// protocol connections. Perspective won’t work if it can’t connect via websocket.

Did some digging, it’s definitely a WebSocket issue for me and appears to be a problem with my Sophos XG router/firewall.

I get a similar error to Paullys50 except that mine says “WebSocket handshake: ‘Connection’ header value must contain ‘Upgrade’”. We have a Sophos UTM 9. I updated the filter options exception list to not block anything from the following URL regex expressions but it doesn’t seem to have done the trick:

  1. ^http?://demo.inductiveautomation.com/.*
  2. ^ws?://demo.inductiveautomation.com/.*
  3. ^wss?://demo.inductiveautomation.com/.*

Maybe I’m missing some URLs or an improper regex expression?

https://community.sophos.com/products/xg-firewall/f/web-protection/84592/when-will-websocket-be-supported

Hmmm

1 Like

Yes I saw that too, updated my firmware this morning…that’s about the extent of my effort for today.