JAR certificate problem

I get an error on one particular computer where the JAR resources are not signed by same certificate (same as this thread: http://www.inductiveautomation.com/forum/viewtopic.php?f=26&t=2685).

I went through those solutions, but no luck yet:

  1. Version mismatches for software would likely cause my applications to not work on any computer, not just one in particular. Further, this thread is from '07, so not sure how to assemble a list of ‘compatible’ packages.
  2. I looked at the Java WebStart cache, which is empty, in my ~/.javaws folder. I also tried clearing the Java cache folder in ~/Application Data/sun/java folder but I get the same error regardless.

Can anyone help me troubleshoot this? I downloaded and installed the latest JAVA version, but it said I already had it (I reinstalled anyway).

Have you tried clearing the Java cache using the Java Control Panel (found in the Windows Control Panel)? What versions of FactoryPMI/SQL/Reporting plugin are you using?


Yes, this problem is due to the way the newest version of Java (6 update 14) changed the way it handles verifying jar signatures. It turns out that the Reporting Plugin jar file was signed with the same signature as the main software, but with a slightly different option (called timestamping), and now Java web start complains about it.

Long story short - download the Reporting Plugin again from here:


and install it by logging into the FactoryPMI Gateway configuration page, go to Plugins > Manage, and add it again.

Thanks Carl - all set.