Java Applet not Working in Ubuntu/Chrome

I am running Ubuntu 10.10 with Chrome 7.0.517.41. Java is installed and when I go to the Java test site: www.java.com/en/download/help/testvm.xml the site indicates that the Java Applet is working correctly in Chrome. It shows that I am using Java 6 Update 20.

However, when I go to the Ignition home page and attempt to start an applet based project, I just get a grey screen. I also tried this on Firefox and got the same result.

I tried it on Windows7 Internet Explorer and it works just fine.

If it matters, I can web launch, non applet Ignition projects in my Ubuntu Chrome browser just fine. I am just having trouble with the Applet launching.

I was able to get applets working fine with these specs:

Ubuntu: 10.10 Desktop 32-bit
Chrome: 8.0.552.215
Java: Version 6 update 22

I would first try by getting the latest java update and see if that helps. If you’re still having problems after that then posting some more information about your system setup would help me to be able to try and recreate the problem.

Dang, that stupid OpenJDK was causing the problem. It must have been re-installed when I upgraded to 10.10.
Once I removed the OpenJDK everything works good now.

Thanks!