Java Error: Failed to validate certificate

#1

Failed to validate certificate. The application will not be executed.
java.security.cert.CertificateException: java.security.cert.CertPathValidatorException: java.security.InvalidKeyException: Wrong key usage

I received this error on a few of my machines after upgrading to 7.4.2 yesterday. Some are running java 6.18 up through 7.04. The only fix seems to be uninstalling java and reinstalling. I tried deleting the cache and the stored certificates but it did not work.

Has any one seen this before or know of a proper fix?

0 Likes

#2

Well, we updated the cert for java web start on 7.4, but only a very few customers are seeing this. Not sure what’s causing it. Which cache did you delete?

0 Likes

#3

I have seen the same thing at some of my client computers.
Downloading and installing the most recent version of Java seems to fix the issue.

I’m not certain, but I think it’s only happening on the machines where I set up a direct link shortcut, as described in this thread:
viewtopic.php?f=70&t=4919

Carl, do you think that direct link shortcut could be the issue?

Cas

0 Likes

#4

I doubt it has anything to do with the direct link. It is something with Java’s cache. Did you try deleting Java’s cache?

0 Likes

#5

No, I’m not at the client’s location anymore, so the simpler thing to ask them to try was the update of Java. That worked, so I moved on to other things…

0 Likes