Java Exception Missing value for query parameters {param_name} even though it's provided?

Am I missing something obvious? I've provided a value for max_count (i've tried both 100 and "100") but keep seeing this error...
DB: PostgreSQL

Type coercion? Data type says string, the expression you have is providing an int. I would expect that to work, but maybe?

See here. I've also tried toStr(100) and referencing a parameter as well (with toStr wrapped around it). I'm a bit confused...

1 Like

Save the project? Relaunch the designer?

Relaunched, same thing :frowning: It works in the Named Query editor in the test tab

Check the raw view JSON? Swap the named query on use to another, commit the binding, swap it back and set it back up?

You're giving me flashbacks to my days in support, Nick :laughing:

Haha "try this!" "nope" "what about this!" "hmm, sort of but nah" " :thinking:"

Oh weird. When I bind any of the 2 parameters to something other than a static value, it fails with the same error. When I set them to integers, it works... Let me keep playing with it

Ok, my bad... I was binding the machine_id parameter to a session prop whose value is None :confused: Whoopsie

Well, that error message sucks if that was truly the root cause, so that's still something for us to fix.