Java 'NoClassDefFound' Error when retargetting on client running Raspberry Pi OS

For machine HMI applications, we currently use ‘system.util.retarget’ in a startup script to switch to a setup app the first time a new HMI started (or client machine is replaced). This works fine for our windows PCs, but I am testing out a Raspberry PI, and I am getting the following error as it launches the re-targeted application.

Retarget error

Gateway Version 7.9.14 (b2020042813)
Client Raspberry Pi 4, model B. Error occurs with both Raspberry PI OS v5.1 and Ubuntu 21.04.

Has anyone else run into this same problem or have any suggestions on a fix?

See this topic:


Phil is on the right track, though it looks like that should have been fixed in 7.9.11.

It’s definitely got something to do with the web browser module not working on RPi systems though.

I would try 7.9.17 or 7.9.18 when it’s released soon and if that doesn’t work call support so this can be tracked as a bug.

1 Like

Thanks for the suggestions. I just tried with version 7.9.17, and it worked.

Also, for clarification for anyone else looking into this, the vision client would open fine, it was only while opening the new client with ‘system.util.retarget’ that this error occurred.