Java problems since updating to FPMI v 2.2.0

I upgraded yesterday to FPMI v 2.2.0 and FSQL v 3.1.5. The first time I ran the Designer and a Windowed or Full Screen project everything worked fine. When I next came to run the designer or a project, I got an Application Error “Unable to launch the application”. Pressing the Details button displayed the following error: JAR resources in JNLP file are not signed by same certificate.

The only way I can get rid of this error is to clear the Java cache every time I shut down the Designer or project. Running the project as an Applet works fine every time.

Has this been caused by the upgrade? How can I recover from this error?


FactoryPMI 2.2.0 uses a new code signing certificate (our old one expired). Java Web Start requires that all JAR files are signed by the same certificate. This means that you must upgrade the Reporting Plugin to version 1.1.2 if you are using FactoryPMI 2.2.0 so that they use the same certificate.

Also, launching from a desktop short cut can cause old, cached JARs to be used and cause this issue. The solution to this is to either clear your Java cache or simply launch from the Gateway rather than the desktop shourtcut. You mentioned that you already cleared your cache, so I doubt its that.

Let us know if the reporting plugin wasn’t the cause.


Upgrading the Reporting Plugin to 1.1.2 sorted the problem - I must have missed this off the list when upgrading.

Thanks for your help.


Don’t worry, you weren’t the only one! We really could use some sort of technical advisory bulletin system…

Glad you got it fixed,