Java utilising 100% CPU after upgrade to V7.4.1

Hi Guys,

I have struck a problem which is causing issues with both the clients and designer. It appears that when anything tries to read data from the gateway it bogs down the system and the Gateways CPU hits 100% usage. Checking the processes it is Java taking the 100%.

When the Ignition service is restarted the CPU hits 100% for several seconds and then settles down to normal 2-4%. Upon opening a client the screens open without issue but data with direct links to the OPC server take up to 20seconds to appear.

within the designer the same occurs with any windows looking to display data.

Any ideas? Logs or other info that will make fault finding this easier?

or will i need to make a backup and unistall / reinstall ignition?

Thanks for any help.


What version did you upgrade from? What do you mean when you talk about reading data;*?*? Just screens bound to SQLTags?

I went from V7.3.4 to V7.4 then quicly to V7.4.1 (64bit Windows Server 2008 R2)

I had no feedback about issues with V7.4

By “reading data” I meant that any TAG (OPC or SQL) eith direct or indirect has a latency before being displayed for the first time.

I performed a couple of tests with creating a new project and tried OPC Tag, SQL memory tag and simulator tags. All were slow to display.

I have a feeling it is more gateway related than Java as every client or designer on any machine has the same issue but Java on the client and ignition server stay at the normal low CPU usage.

EDIT: I have now witnessed the Ignition server CPU hitting 100% (Java) when a client first opens to a window which shows OPC data.


Just an Update

I created a new ignition setup on another PC then created a new project and everything worked as it should.

I then exported projects from my troubled system and found they worked without issue on the new system.

I then created a backup of the troubled system and restored it onto the new system. This caused the new system to slow down and behave with the same issues. Restoring a backup from the new system fixed it again.

In the end I have imported all the projects into a fresh build and all is working well. Obviously something broke when I upgraded??


There have been a few people report that their client poll rate gets set to something like 5 seconds after updating, which could cause the symptoms you are seeing…