JDBC and AutoCommit

I’m using the JDBC connector for a different Database but I’m having a problem when writing to the database using the SQL Bridge for a Historical Group. The JDBC is trying to set AutoCommit, which apparently is an optional function that is not supported by the JDBC driver (Simba for BigQuery). Is there any way to disable this?

Unfortunately no, setAutoCommit is called all over the code base, with true or false, depending on the context, with no notion that it might not be supported. That’s the first I’ve ever heard such a thing.

Thanks. It has been hard to do this connection with BigQuery. It does not have transactions, as well PK and indexes. I could manage the index adding “Select 1” on the translator for index creation and it went through. Do you imagine any workaround like that I could use?

was curious about this one

are you able to set IgnoreTransactions flag. It seems to be a solution for ODBC that, I hope, should also work with JDBC


Beautiful! It worked like a charm! Thank you very much! I was trying so many paramaters names to reach something like this! LOL