Kepware Bad_UserAccessDenied

Edit: this post was separated out from the topic in the referenced link.

I have this same issue, I have tried all sorts:

  • enabling anonymous user and setting no username/password in Ignition UA client config. I still get this error…
  • disabling anonymous user and setting username/password in Ignition UA client config to the Administrator, then I get aServiceFaultException: status=Bad_UserAccessDenied, message=User does not have permission to perform the requested operation. even though the Administrator has literally every single security privilege set to Allow…

I’ll have no hair by the end of this haha.

Have you set Kepware to “Trust” the connection?

It never got that far, but yes, I imported the ignition server certificate into the Kepware OPC-UA server to make it a trusted client.

I managed to get this working, albeit not how I’d like, by installing KepServerEx on another server. The issue seemed to occur when you choose to set a password up when you first install KepServerEx. The first time I set a password up, but the second time I skipped this. Uninstalling it and reinstalling it does not remove this password and so my only other option was to install it elsewhere… Luckily it’s OPC-UA and not OPC-DA!

I made the same mistake by living the password blank, but I discovered there is a way to add the password back.
For Windows users, if you go and click on the hidden icons in your taskbar, then right-click on the Kepware icon, then select “Settings”, click on the tab “user manager”, click on “administrator” and it will let you add the password.

After that, go back to the gateway and add the password to your OPC connection.

P.S. I’m using version 6.11

1 Like