L5K Parser Issues

I started trying to test out the L5k Parser that was posted in the exchange and I’m having some issues. It seems to not like AOIs in general. I tried it with a couple different programs (with different AOIs) and firmware versions. I’ve been getting some variation of the error below in the logs whenever there was an AOI in the L5K and I went to import it.

Has anyone else run into this or do I need to do something that I’m missing?

Error running action 'component.onFileReceived' on L5K/Parser@C/root/FileUpload: Traceback (most recent call last): File "<function:runAction>", line 6, in runAction File "<module:L5K.Parser>", line 285, in parse File "<module:L5K.Parser>", line 20, in search AttributeError: 'NoneType' object has no attribute 'groups'

Do you have a link or copy of the code? Looks like like line 20 of L5k.Parser you have a line someVariable.groups but someVariable is None. Also provide what data you are feeding the functions.

In general to get the best feedback from these forums, provide the broken code, your inputs, your expected outputs, and what your current output is. Also what version of Ignition can sometimes be important so that is always useful to provide.

Hi b.peck! Can you send me your L5K file so I can take a look at it. The issue has something to do with add on instructions but I am not getting that error with the L5K file that I have. Send it to travis@inductiveautomation.com.

Once I have it, I can get this fixed.

I was just missing an edge case with add on instructions. Essentially, you can have a tag reference, TAG OF ANOTHERTAG.1. I created a new version that fixes the issue. You can find it here:


1 Like

Travis, I just tried and get an error parsing, try again later. I will email my L5K file.