Launch designer straight into a project

Just a quick question, is it possible to make the designer launcher .jnlp open straight into a given project? I don’t usually deal with multiple projects on the same gateway so it’d be nice if I could just skip that step most times.

Just add a command line argument (or use the NCL, with the same argument)

Could you please clarify? I’ve tried this several ways and I’ve had no luck. Usually I launch it by double clicking the .jnlp of the designer I want to open, so I’ve tried making a shortcut to it and adding that argument, substituting Test with my project name. I’ve also tried opening directly from the command prompt with that argument. Both work, but still open up to the project select window.

Adding arguments to the JNLP is non-trivial (why the NCL is recommended!). You’ll have to edit the body of the .jnlp file (it’s just text) to add the argument/value:

I should have mentioned, I had come across that link and tried that as well with no luck. Tried all sorts of variations of

I’ve never had a lot of luck with the NCL, to be honest. Trying it again here and something different is happening, at least. I was able to get the shortcut with the target (though its a local IP, still X’d out the ip)

C:\Users\mirogers\Downloads\clientlauncher.exe scope=D windowmode=window gateway.addr=X.X.X.X:8088/main

This opens up a popup window that just says “Downloading Projects” and disappears after a couple seconds, then there’s no trace of it. I’ve also tried project=ObjectLibrary (because the client launchers I downloaded through the NCL used that format), but that just brought me to the project selection popup again.

Whoops, my bad. I copied the directly from my IDE configuration, didn’t bother to look at the code. You need to specify two arguments to launch directly into a project:
clientlauncher.exe gateway.addr=localhost scope=D -Djavaws.ignition.debug=true


Theeeeeere we go, works great!

1 Like

Is there a way to do this without enabling debug mode? The reason I ask is there’s one page with a lot of templates on it in one project we work with that works fine in clients and designer when debug mode is not enabled, but chokes CPU in Designer when debug mode is on. If opened this way, the only way it’s useable is if we open Diagnostics and change all the logging levels from DEBUG to INFO or less before opening the page. Otherwise we end up killing Designer with Task Manager and then re-opening it.

It’s not possible without enabling debug mode. This was never meant to be a user-facing feature.

Thanks for confirming. While opening straight to projects is slick, the extra click to open isn’t so bad. We’ll go through the project selection screen for this project.