Launch Staging with Zulu JRE

Is there a way to launch the staging version of a project using Zulu JRE?

What version of ignition are you using? if you are on 8.0+ then no. staging and publishing has been removed in favor of (the recommended) development and production gateway configuration.

thanks,
Jonathan C

7.9.6

On 7.9.6, we’re just going to be using whatever your system’s JRE is - so if you have a Zulu JRE installed, and properly set as your default (OS-specific, but basically set JAVA_HOME=<your JRE install directory>) that’s what the client/designer will use.

It says there is no Java Webstart.

IOException: Cannot run program “javaws”: CreateProcess error=2, The system cannot find the file specified
caused by IOException: CreateProcess error=2, The system cannot find the file specified

Ignition v7.9.6 (b2018012914)
Java: Azul Systems, Inc. 1.8.0_232

So, if your JRE doesn’t include javaws, that’s up to your JRE. You can use the native client launchers, which don’t require javaws, because they don’t use JNLPs to launch:
https://docs.inductiveautomation.com/display/DOC79/Native+Client+Launchers

Great, how do I launch the staging version of a project with he native client launcher?

Add -Djavaws.sr.project.version=Staging to the command line; exactly where to put that can vary but there’s details at the end of the user manual article.

1 Like

Ignition: 7.9.17
Java: OpenJDK 1.8.0_322

Running the following, with the values in <> replaced, keeps throwing an exception.

comand

C:\Ignition\ClientLauncher\clientlauncher.exe project=<project-name> gateway.addr=<ip-address>:80/main scope=C windowmode=window -Djavaws.sr.project.version=Staging

exception

Java process launch failed with error code 1: Error: Could not find or load main class me

I have also tried passing tag values, per the docs and I get the same error, but sometimes with a different class name.

Could someone point me in the right direction?

Can you get the full error? What you provided looks cut off.

edit: also you’re not including the angle brackets in the project argument, right?

Woops…just found the problem. I was somehow passing in an object instead for the project name.
There is no issue.