Level Indicator overlays

One of the things I noticed while upgrading from FactoryPMI to Ignition is the change in behavior of the Level Indicators. Namely, if the value is < 0 or > capacity, it displays the “limit exceeded” overlay.

I find it’s pretty common to have level transducers that are not perfectly calibrated, so often a tank or whatever will be empty and the level reading is something like -2%. That, to me, seems to be a much less severe case than a communications error.

I think it would be nice to have a check box or whatever that made that particular overlay optional. I realize this can be fixed by just coercing the value with an expression, but that’s a bit of a nuisance.

Two options:

  1. every binding has an overlay opt out checkbox. usually near the bottom right of the popup. Check this and no overlay will bother your operators again.

  2. When you apply scaling to a tag, you can set the clamp mode to prevent it from exceeding the full value limits.

hmm. I tried this on a tank component.

Unfortunately even after checking the “overlay opt out” check box on the ‘Value’ binding. It is still showing up with the overlay in the designer.


I’d prefer not to use the clamp as I’d prefer for operators to still be able to see sensors not operating correctly i.e. failed high. Clamping the value to within range will prevent them from

I posted a tank display here That may give you some ideas.

So what is the point of the “overlay opt out” check box?

edit. Found the answer in the manual. Has nothing to do with whether out of range or not

Overlay Opt-Out
Choosing this option will ignore the quality of the chosen tag, making it have no effect on the component’s quality overlay.

Yeah, the Overlay Opt-out doesn’t seem to apply to this particular overlay. What I did wind up doing to get around this was to bind the level value to an expression that coerced the tag in question to be > 0 and < capacity, removed the level’s numeric display, and added a numeric indicator bound to the uncoerced tag value.